Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 157574

Summary: some fence modules support extraneous attributes
Product: [Retired] Red Hat Cluster Suite Reporter: Lon Hohberger <lhh>
Component: fenceAssignee: Jim Parsons <jparsons>
Status: CLOSED NOTABUG QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-18 18:23:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lon Hohberger 2005-05-12 19:33:44 UTC
Description of problem:

Some fence modules support multiple different attribute names for the same
setting.  For instance, they might accept "passwd" or "password" - which is bad,
because only one will be correctly handled.

Comment 2 Jim Parsons 2005-12-20 14:59:57 UTC
I would love to address this for U4 - along with a comprehensive catalog of
every mutable parameter available in cluster.conf...the public has been crying
out for this :-)

Comment 4 Jim Parsons 2006-10-18 18:23:21 UTC
A comprehensive catalog of fencing parameters has been published at
http://sources.redhat.com/cluster/doc/cluster_schema.html

Closing this bug. Feel free to reopen if it is desired that resources be spent
on allowing stdin args for all fence agents to work with passwd as well as password.