Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 157568

Summary: Crash opening personal/Inbox on Exchange server
Product: Red Hat Enterprise Linux 3 Reporter: Dave Malcolm <dmalcolm>
Component: evolution-connectorAssignee: Dave Malcolm <dmalcolm>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: benl
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-03-24 04:18:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 170445    

Description Dave Malcolm 2005-05-12 19:11:20 UTC
Description of problem:


Version-Release number of selected component (if applicable):
evolution-1.4.5-14.x86_64
evolution-connector-1.4.7-5.x86_64

How reproducible:
100% so far

Steps to Reproduce:
1. Create Evolution account linked to an Exchange server
2. Browse mail, Personal folders: Inbox

  
Actual results:
Evolution segfaults

Expected results:
Emails should appear

Additional info:

Comment 1 Dave Malcolm 2005-05-12 19:13:19 UTC
Crash is in here:
#0  exchange_get_folder (store=0x2a9f416d10, folder_name=0x2a9f411231
"personal/Inbox", 
    camel_flags=2671771832, ex=0x9cdd00) at camel-exchange-store.c:304
#1  0x0000002a9dbf2614 in disco_get_folder (store=0x2a9f416d10,
name=0x2a9f411231 "personal/Inbox", 
    flags=0, ex=0x9cdd00) at camel-disco-store.c:225
#2  0x0000002a9dc28aec in camel_store_get_folder (store=0x2a9f416d10, 
    folder_name=0x2a9f411231 "personal/Inbox", flags=0, ex=0x9cdd00) at
camel-store.c:241
#3  0x0000002a9da6dbc0 in mail_tool_uri_to_folder (uri=0x2a9f416510 "p",
flags=0, ex=0x9cdd00)
    at mail-tools.c:336
#4  0x0000002a9da66eb4 in get_folder_get (mm=0x9cdcd0) at mail-ops.c:1305
#5  0x0000002a9da63481 in mail_msg_received (e=0x2a9f4164a0, msg=0x9cdcd0,
data=0x2a9f4000b8)
    at mail-mt.c:503
#6  0x0000002a95b0b0e2 in thread_received_msg (e=0x643720, m=0x9cdcd0) at
e-msgport.c:617
#7  0x0000002a95b0b20e in thread_dispatch (din=0x2a9f4164a0) at e-msgport.c:698
#8  0x0000002a98971c64 in start_thread () from /lib64/tls/libpthread.so.0
#9  0x0000002a993ddec3 in thread_start () from /lib64/tls/libc.so.6
#10 0x0000000000000000 in ?? ()

Value of local variable "folder" appears to get corrupted at some point from it
allocation at:
	folder = (CamelFolder *)camel_object_new (CAMEL_EXCHANGE_FOLDER_TYPE);
(gdb) p folder
$13 = (CamelFolder *) 0x2a9f41d560

and the line
	camel_object_ref (CAMEL_OBJECT (folder));
(gdb) p folder
$14 = (CamelFolder *) 0x2a00000000


Comment 2 Dave Malcolm 2005-05-12 19:14:44 UTC
(Looks like final 32 bits are getting zeroed; possible 32/64 bit mismatch?)

Comment 3 Dave Malcolm 2005-05-13 00:03:11 UTC
Looks like a dup of 144817