Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156824

Summary: ppc boot dies at video change for Tux
Product: [Fedora] Fedora Reporter: John Reiser <jreiser>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: byte, dwmw2, pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-28 00:22:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description John Reiser 2005-05-04 14:53:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
Booting 2.6.11-1.1284 fails on Mac mini PowerPC at the change in console video just before displaying Tux the penguin and scrolling boot messages.  CRT display (ViewSonic A50) goes to DPMS Suspend Mode, then there is no evidence of further activity: screen stays dark, no noise of disk seeks.  Ctrl-Alt-DEL gets no response.  kernel 1282 works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot 1.1284 on ppc Mac mini

Actual Results:  At the console video change that would display Tux the penguin and scrolling messages, instead the monitor goes to DPMS Suspend Mode, and nothing further happens.

Expected Results:  Normal boot.

Additional info:

Comment 1 John Reiser 2005-05-09 14:24:06 UTC
It now "works for me" with:
selinux-policy-targeted-1.23.14-2  [targeted enforcing]

Comment 2 John Reiser 2005-05-17 16:39:55 UTC
The problem stayed away up to and including:
  selinux-policy-targeted-1.23.14-2  [targeted enforcing]

but reappeared today (FC4 test 3) with:
  selinux-policy-targeted-1.23.14-2  [targeted permissive]
in the form of "FREQUENCY OVER RANGE" (and boot hangs) at the video change that
would show Tux and scrolling VGA text.  This is on PowerPC Mac mini, ATI Radeon
9200, ViewSonic A50 monitor with DDC (works under X11 in 1024x768 @70Hz,
thousands of colors).

Also, the kernel changelog for .1312 says nothing about changing startup video.
 So why does the behavior change?  Change to Reopen.

Comment 3 Dave Jones 2005-05-18 00:37:16 UTC
dwmw2, could this be something I over-zealously pruned during the rc3->rc4 rebase ?

Comment 4 John Reiser 2005-05-18 03:39:54 UTC
Now it's intermittent, and usually if I wait long enough (75 seconds: 1.3
minutes) then the X11 login screen does appear, and I can login.  So maybe I was
too impatient in the earlier reports.  However, bug #157658 did happen once
(hang with agp or serial as last VGA text message), and that did not recover.

I attempted booting kernel .1312 three times in a row (as the default: l,
<ENTER> to yaboot) and got FREQUENCY OVER RANGE from the monitor.  Each time, I
turned off the power strip, waited 10 seconds, turned on the power strip, and
tried booting again.  After the third failure, I booted .1305 successfully, then
shutdown for dinner.

A couple hours later, I tried booting 15 times.  Five times with .1312, then
five times with .1305, then five times with .1312 again.  The results were:
1. FREQUENCY OVER RANGE; impatient power cycle (waited only 30 seconds).
2. success all the way to X11; login, then shutdown.
3. success all the way to X11; login, then shutdown.
4. success all the way to X11; login, then shutdown.
5. success all the way to X11; login, then shutdown.

6. DPMS SUSPEND; but I heard the disk seeking, so I put my ear next to the box,
waited as long as I heard seeks (a little more than a minute,) and the X11 login
screen appeared!  login, then shutdown.
7. success all the way to X11; login, then shutdown.
8. hang same as bug #157658 (last lines on VGA text are "agpgart: AGP aperture
is 16M @ 0" and "Serial: 8250/16550 driver ...".  Power cycle the box.
9. success all the way to X11; login, then shutdown.
10. success all the way to X11; login, then shutdown.

11. blank screen (no on-screen diagnostics from CRT hardware), but X11 screen
appears after more than a minute.  login, then shutdown.
12. success all the way to X11; login, then shutdown.
13. FREQUENCY OVER RANGE; wait 75 seconds, then X11 screen appears.  login, then
14. success all the way to X11; login, then shutdown.
15. success all the way to X11; login, then shutdown.

So with the exception of trial #8 which did hang, it now looks like "only video"
is the problem.

Comment 5 Colin Charles 2005-06-13 21:42:48 UTC
So, this is confirmed to be some form of radeonfb bug. Passing:
linux video=ofonly 

should make it work. We need to look for more obvious changes from the kernel in
FC4t3 -> dist-FC-4's kernel... 

Comment 6 Dave Jones 2005-06-27 23:13:53 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done


Comment 7 John Reiser 2005-06-27 23:45:56 UTC
Booting FC4 final release kernel-2.6.11-1.1369_FC4 on Mac mini (PowerPC32) now
goes farther.  However, X11 still does not start.  The symptom is now the same
as reported in bug #158922: no screens found [(EE) Screen(s) found, but none
have a usable configuration.]

Comment 8 Dave Jones 2005-06-28 00:22:26 UTC
Ok, closing this as the initial bug sounds like its resolved.