Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156736

Summary: kernel-smp-2.6.11-1.1282_FC4 fails to boot on x86_64
Product: [Fedora] Fedora Reporter: Bryan O'Sullivan <bos>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 4CC: jrodary, pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-06 20:23:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
crash.log none

Description Bryan O'Sullivan 2005-05-03 18:59:23 UTC
Description of problem:

Looks like it can't load sd_mod during early boot, and panics.

Version-Release number of selected component (if applicable):

kernel-smp 2.6.11 1.1282_FC4 x86_64

How reproducible:

100%
  
Actual results:

I'll attach a console log. It's a bit mangled, but serviceable.

Comment 1 Bryan O'Sullivan 2005-05-03 19:01:35 UTC
Created attachment 113978 [details]
crash.log

The oops would have to be decoded by hand, but I think it's the module load
that triggers it.

Comment 2 Dave Jones 2005-05-09 23:53:09 UTC
it looks like your initrd is broken at first guess.
Still happening with subsequent kernels ?


Comment 3 Jacques Rodary 2005-06-27 22:34:11 UTC
I have a similar problem with kernel-2.6.11-1.1369_FC4
 and kernel-smp-2.6.11-1.1369_FC4 on a i386 smp box, with only scsi disks. Here
is the error log:
     Creating root device
     Mounting root filesystem

 

Comment 4 Jacques Rodary 2005-06-27 22:46:27 UTC
I have a similar problem with kernel-2.6.11-1.1369_FC4
 and kernel-smp-2.6.11-1.1369_FC4 on a i386 smp box, with only scsi disks. Here
is the error log:
     Creating root device
     Mounting root filesystem
     mount: error 6 mounting ext3
     Switching to new root
     ERROR opening /dev/console!!!!: 2
     error dup2'ing fd of 0 to 0
     error dup2'ing fd of 0 to 1
     error dup2'ing fd of 0 to 2
     unmounting old /proc
     unmounting old /sys 
     Keenel panic
Happily enough I had a custom kernel which runs. Everything was OK with  RedHat
or Fedora Kernels till now, and that surprised me, as the kernel config tells
you to load scsi adapter *not* as a module if your root filesystem is an scsi disk! 

Comment 5 Jacques Rodary 2005-07-10 14:28:33 UTC
Still happening with kernel-2.6.12-1.1387_FC4 kernel-2.6.12-1.1390_FC4
kernel-smp-2.6.12-1.1387_FC4 kernel-smp-2.6.12-1.1390_FC4 and I even tried to
make a new initrd!

Comment 6 Dave Jones 2005-10-06 05:42:18 UTC
How about the latest errata ? 



Comment 7 Bryan O'Sullivan 2005-10-06 18:42:29 UTC
Seems OK, thanks.  I think you can close this if you want to.