Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156310

Summary: docs: patch installation timestamps
Product: Red Hat Satellite 5 Reporter: Máirín Duffy <duffy>
Component: Docs Reference GuideAssignee: John Ha <jha>
Status: CLOSED NOTABUG QA Contact: Steve Salevan <ssalevan>
Severity: medium Docs Contact:
Priority: medium    
Version: 500CC: adstrong, bnackash, msuchy
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-28 20:27:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Máirín Duffy 2005-04-28 20:23:39 UTC
If a patch / (maybe patchset / package?) is installed on Solaris via RHN, then
we can track and display the date of the last installation in the lists that
display patches for a particular system.

However, if a patch (patchset / package??) has been installed on Solaris without
RHN, directly on the machine, then we cannot track the date of the last install.
In this situation, we will display "not available."

It may be nice to have a note about what this "not available" means in the
documentation.

Comment 1 Máirín Duffy 2005-04-28 21:19:12 UTC
I have confirmed with shughes that this issue applies to patchsets and packages
on Solaris systems as well.

Comment 2 Mark Johnson 2005-07-20 18:48:59 UTC
punting this doc bug to 4.1 b/c there is a bigger problem in that the "Patch
Type" and "Last Installed" fields read "unknown" and "Not Available", resp, even
in the case where the patches/clusters *are* installed via RHN. 

See http://lacrosse.corp.redhat.com/~mjohnson/RHN/unix/figs/patch-foo.png for a
visual example of what we're talking about here.

jmartin is filing a bug report on this issue.

Comment 3 Max Spevack 2005-07-27 20:35:38 UTC
new Sol component created/QA contact should be mspevack if not already

Comment 4 Max Spevack 2005-08-12 14:54:03 UTC
please see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=163843

Comment 5 Beth Nackashi 2006-04-22 18:10:32 UTC
bperkins is QA contact for all Solaris bugs

Comment 6 Melissa Goldin 2006-05-04 13:13:27 UTC
Mass adding keyword 'Documentation' to all bugs

Comment 7 Melissa Goldin 2006-07-11 16:23:05 UTC
This has been punted to rhn420-solaris.  Also aligning with the Ref Guide for 420.

Comment 8 Melissa Goldin 2007-02-05 18:59:38 UTC
Removing from the RHN 500 Hosted release, because rhn420-solaris now points to
rhn510s-triage.

Comment 9 Michael Hideo 2007-06-06 04:44:22 UTC
Adding 'cc ecs-dev-list@redhat.com for tracking

Comment 10 Michael Hideo 2007-06-20 01:30:59 UTC
Moving Bugs to John Ha and assigning.

Re-prioritization meeting on June 20, 7PM EST.

Comment 11 John Ha 2007-08-04 13:36:46 UTC
acking for 510 release.

Comment 12 Michael Hideo 2007-10-23 02:45:18 UTC
Removing automation notification

Comment 13 John Ha 2007-12-20 23:57:12 UTC
Is what is stated in Comment #2 still valid? Is there still a documentation need
for this issue as it seems to affect all packages/patches regardless of whether
they were installed by RHN or not.

Either way, we don't have time put this in the 5.1.0 release :(

Comment 14 Brandon Perkins 2008-02-08 14:57:13 UTC
I don't personally think we need it... but as mizmo was the one to report it,
I'll let her decide.

Comment 15 Máirín Duffy 2008-02-08 15:05:28 UTC
wow blast from the past!!

if it affects all patches regardless of how they were installed then it's
definitely not needed. back when i filed that we didn't have a standard method
of doing contextual tool tip thingys but now that we do i think if the behavior
did differ, it'd be better to put a tooltip below the patch list rather than put
the info in the docs. so feel free to close this :)

Comment 16 John Ha 2008-10-28 20:27:39 UTC
Performing 5.3.0 cleanups. Closing this as the reporter sees no docs need for it.