Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156255

Summary: Formulas are shown as objectX in impress
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-28 15:56:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
document showing the described behaviour none

Description Hans de Goede 2005-04-28 14:41:46 UTC
The formulas on slide 88 and further in the attached .sxi (once a ppt, but
converted to sxi with 1.1) are shown as objects instead of formulas.

Funny enough opening the same file as ppt exported from oo-1.1 does show the
formulas, but they can't be modifed, which used to be possible under 1.1 .

Comment 1 Hans de Goede 2005-04-28 14:41:47 UTC
Created attachment 113785 [details]
document showing the described behaviour

Comment 2 Caolan McNamara 2005-04-28 15:05:23 UTC
could you attach a screenshot, it looks ok for me in 1.9.96-2. 

For the .ppt exported from 1.1 and opened in 2.0 this is probably something like
the settings of the tools->options->load/save->Microsoft Office for handling
embedded objects, where it's probably enabled in 1.1 so they are saved as ms
equation editor objects, and disabled in 2.0 so they are not converted back to
(oomath options on load (done because this is *so* slow).

Comment 3 Hans de Goede 2005-04-28 15:56:24 UTC
Erm,

Installing openoffice.org-math fixes this, will anacondo do the right thing when
upgrading the old monolithic ooo to the new modular?

Closing.


Comment 4 Caolan McNamara 2005-04-28 16:04:54 UTC
yeah, even right now if start off with ooo1.1.1 you'll get
-core,-writer,-impress,-draw,-math,-calc

Comment 5 Hans de Goede 2005-04-28 16:12:20 UTC
Cool and thanks for the tools->options->load/save pointer that fixes the ppt import.