Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156240

Summary: php-pecl-sqlite - FC4 rebuild failed
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: php-pecl-sqliteAssignee: Matthias Saou <matthias>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-08-03 14:59:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 157183    

Description Michael Schwendt 2005-04-28 13:19:18 UTC
This package failed to rebuild for FC4 Development around 2005-04-11 after an
automated release bump.

Build failure logs at: http://fedoraproject.org/extras/development/build-logs/

Comment 1 Matthias Saou 2005-05-03 13:38:55 UTC
This package isconsidered obsolete by its author. Apparently, sqlite v2 support
(this module) is now included in PHP 5.x, although I'm not sure it's enabled in
the Fedora Core packages, and the author now focused on an sqlite v3 module
which uses PDO, and rebuilds fine on FC4.

I'm not sure what to do here, but my choice would be to drop this module and
start packaging the PDO one instead, although without including any kind of
obsoletes since both are quite different.

Yet an extra tricky step for PHP migrations from 4.x to 5.x...

Thoughts?

Comment 2 Matthias Saou 2005-05-20 11:35:06 UTC
No thoughts... well, only mine, so I'll push the php-pecl-pdo and
php-pecl-pdo-sqlite packages I have into Extras development.

Comment 3 Matthias Saou 2005-08-03 14:59:30 UTC
Resolving as WONTFIX since php-pecl-sqlite has now been been replaced by
php-pecl-pdo-sqlite. I've also requested the removal of the non working FC-3
packages that had been copied over to the FC-4 tree.