Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156228

Summary: inkscape - FC4 rebuild failed
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: inkscapeAssignee: Phillip Compton <compton>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: ivazqueznet
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-31 16:47:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 156443, 157183    
Attachments:
Description Flags
Patch for gcc4 build none

Description Michael Schwendt 2005-04-28 13:14:21 UTC
This package failed to rebuild for FC4 Development around 2005-04-11 after an
automated release bump.

Build failure logs at: http://fedoraproject.org/extras/development/build-logs/

Comment 1 Michael Schwendt 2005-05-07 21:35:17 UTC
http://extras64.linux.duke.edu/failed/development/inkscape/0.41-2/x86_64/

Assumedly, the x86_64 build would fail in more than just the line, which was the
first fatal error.

Debian's package contains several patches, including one for AMD64:
http://packages.debian.org/unstable/graphics/inkscape

Comment 2 Ignacio Vazquez-Abrams 2005-05-10 09:59:16 UTC
Created attachment 114197 [details]
Patch for gcc4 build

Give this a try. I was unable to verify it due to a FC3/gcc4/gtkmm24 bug
(#15293), but it should work.

Comment 3 Lars G 2005-05-12 16:50:09 UTC
does this patch work?
would be great to have a new rebuild, because currently inkscape freezes the gui
when
using rawhide.

Comment 4 Jeremy Katz 2005-05-26 01:28:33 UTC
ignacio's patch started on the path of fixing, but there were a number of 64bit
cleanups needed.  Fix committed and build queued.

Comment 5 Michael Schwendt 2005-05-30 23:09:41 UTC
-4 failed in build system setup build-minimal => bumped to -5 and requested rebuild

Comment 7 Michael Schwendt 2005-05-31 16:47:51 UTC
0.41-7 did succeed.