Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156168

Summary: candidates window is empty when used with iiimx
Product: [Fedora] Fedora Reporter: Lawrence Lim <llim>
Component: iiimfAssignee: Jens Petersen <petersen>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: eng-i18n-bugs, tools-bugs
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-03 07:58:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 125997, 157496, 157800, 158504    

Description Lawrence Lim 2005-04-28 04:52:28 UTC
Tracking:
http://openi18n.org/mantis/bug_view_page.php?bug_id=0000078

Version:
iiimf-le-chinput-0.3-19

Comment 1 Yu Shao 2005-06-08 05:46:20 UTC
Ok, chinput LE send to both iiimf-gtk and iiimf-x this string to display "0x31 
0x0  0xa2  0x7e" the candidates, however iiimf-gtk is ok to handle it but not
iiimf-x, and iiimf-x was ok with 12.1-10.EL(RHEL4). Do we have any work done
since RHEL4 on iiimf-x?


Comment 2 Yu Shao 2005-06-08 05:59:48 UTC
"0x31 0x0  0xa2  0x7e" is UTF16 encoded string for "1红".

Comment 3 Akira TAGOH 2005-06-09 07:44:39 UTC
AFAICS there was some changes related to the rendering from IBM patches.

Comment 4 Yu Shao 2005-06-10 05:11:54 UTC
Reassigning bug to iiimf.

Comment 6 Jens Petersen 2005-10-03 05:00:54 UTC
Can this still be reproduced with U2?

I thought I reproduced it the other day with 12.1-13.EL.2
but today I can't see to.

Comment 7 Lawrence Lim 2005-10-03 07:39:01 UTC
Works fine in U2. But in rawhide, the status window is blank. fonts-chinese has
been installed.