Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 156093

Summary: kde hangs and (frequently) causes kernel panic after changing default style to "KDE Classic"
Product: Red Hat Enterprise Linux 4 Reporter: Jeff Woods <jcwoods>
Component: kernelAssignee: Jason Baron <jbaron>
Status: CLOSED WORKSFORME QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: knoel
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-28 21:31:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeff Woods 2005-04-27 14:38:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
After logging into kde and attempting to change to the "Classic KDE" style from the default Bluecurve style, kde hangs.  At times, the hang has impacted either the kcontrol window only, while at others it will hang X.  Shortly after (randomly, it seems...), the machine will halt with a kernel panic.

The kde and related packages installed include:

kdeaddons-3.3.1-2
kdeadmin-3.3.1-2
kdeartwork-3.3.1-2
kdeartwork-icons-3.3.1-2
kdebase-3.3.1-5.5
kdegames-3.3.1-2
kdegraphics-3.3.1-3.3
kdelibs-3.3.1-3.6
kdemultimedia-3.3.1-2
kdenetwork-3.3.1-2
kdenetwork-nowlistening-3.3.1-2
kdepim-3.3.1-2.1
kdesdk-3.3.1-2
kdeutils-3.3.1-2
arts-1.3.1-2
qt-3.3.3-9.3
qt-MySQL-3.3.3-9.3

I have been able to duplicate this problem on two different workstations (a Dell Optiplex 260 and a Dell Optiplex 270).

Version-Release number of selected component (if applicable):
kdebase-3.3.1-5.5

How reproducible:
Always

Steps to Reproduce:
1. Log into kde
2. Alt-F2, and start kcontrol
3. Select "Desktop->Styles" (from memory... may not be correct!)
4. Change style from Bluecurve to KDE Classic
5.  Press the "Apply" button at the bottom of the kcontrol window.

At this point, either the kcontrol window will become unresponsive or the entire X session will freeze (which requires a ctrl-alt-backspace to recover).  Almost without fail, the system will hang with a kernel panic within a few minutes.  The kernel panic has occurred during a shutdown (following a "reboot" command issued from the console), after logging out of kde and into Gnome, and while working on a virtual console (Ctrl-Alt-F1).  Before attempting to change the style, KDE and the system are stable.

It is interesting to note that I've used this hardware with Gnome for the better part of two days without trouble.  Once, I even quit out of kde after kcontrol became unresponsive, logged into Gnome (so I could work), and then the kernel panic occurred (while in gnome).

Actual Results:  At this point, either the kcontrol window will become unresponsive or the entire X session will freeze (which requires a ctrl-alt-backspace to recover).  Almost without fail, the system will hang with a kernel panic within a few minutes.  The kernel panic has occurred during a shutdown (following a "reboot" command issued from the console), after logging out of kde and into Gnome, and while working on a virtual console (Ctrl-Alt-F1).  Before attempting to change the style, KDE and the system are stable.

It is interesting to note that I've used this hardware with Gnome for the better part of two days without trouble.  Once, I even quit out of kde after kcontrol became unresponsive, logged into Gnome (so I could work), and then the kernel panic occurred (while in gnome).

Expected Results:  Style should have been changed

Additional info:

Comment 1 Ngo Than 2005-04-27 15:00:17 UTC
It seems a bug in kernel or X. I'm not able to reproduce this problem.
could you please attach the messages from kernel crash? thanks

Does the problem appear in gnome if you change the gnome setting with
gnome-control-center?

Comment 2 Jeff Woods 2005-04-27 15:51:12 UTC
The only message I've seen (when I was logged in on the virtual console -- not
in X, where I get no messages) is:

kernel panic - not syncing: Attempting to free lock with active block list.

I know there are other messages (registers, stack frame, etc), but am not sure
how to get to them.  How can I capture the crash messages to a file?

Comment 3 Jeff Woods 2005-04-27 21:12:24 UTC
Was this bug intentionally closed?  If so, should I open a ticket against X?  I
don't have a resolution.

Comment 4 Dave Jones 2005-05-01 08:28:59 UTC
unfortunatly at the time of a kernel panic, the system isn't in a state where
its safe to write files, so the best way of getting the info out of this would
probably be netconsole if you've got another computer on the same network.

netconsole is pretty easy to set up.
On the other box, do..
nc -u -l 4444 

and on the box you're seeing this problem, run..
modprobe netconsole netconsole=@/,4444@1.2.3.4/

(replace 1.2.3.4 with the IP address of the other box).

Now any kernel messages should come out on the terminal of the other box.


Can you attach a dmesg & lsmod too please ?


Comment 5 Jeff Woods 2005-06-28 21:30:09 UTC
I believe that this was a problem related to the video card and/or X driver. 
The workstation has recently been replaced, and I can no longer reproduce the
problem.

This ticket may be closed.

Comment 6 Jeff Woods 2005-06-28 21:31:40 UTC
I believe that this was a problem related to the video card and/or X driver. 
The workstation has recently been replaced, and I can no longer reproduce the
problem.

This ticket may be closed.