Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155988

Summary: yum is treating kernel-devel and kernel-smp-devel package
Product: [Fedora] Fedora Reporter: Jef Spaleta <jspaleta>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: david_kewley, katzj, pfrields, thomas.duffy.99, tjb
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-08-26 01:52:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 136450    

Description Jef Spaleta 2005-04-26 14:02:24 UTC
Description of problem:
kernel-devel package is treated as installonly
kernel-smp-devel is updated

They should be treated the same way.. which way they are both treated is a
matter of opinionated opinion. I've brought this up in fedora-packaging list as
per seth's request.. but the discussion sort of died without a clear consensous.
I'm filing this to make sure the issue isn't forgotten.  

Version-Release number of selected component (if applicable):
yum-2.3.2-1

Comment 1 Jeremy Katz 2005-04-26 15:38:54 UTC
Would a generic
  Provides: kernel-devel
in kernel-devel-smp help?  Seems like the low-hanging way to fix this.

Comment 2 Seth Vidal 2005-05-10 03:55:30 UTC
fixed in yum upstream

i just added kernel-smp-devel to the installonly list in the default config.

Comment 3 Jeremy Katz 2005-05-10 12:33:28 UTC
*** Bug 156741 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2005-05-10 12:41:08 UTC
But adding these to the yum config is going to be ugly and really shouldn't be
needed anyway.  If we do it in yum, then we need to also add -xen0-devel and
-xenU-devel and then when we collapse the xen packages, -xen-devel.  It seems
far simpler to do the following in the kernel spec file

Index: kernel-2.6.spec
===================================================================
RCS file: /cvs/dist/devel/kernel/kernel-2.6.spec,v
retrieving revision 1.1291
diff -u -u -r1.1291 kernel-2.6.spec
--- kernel-2.6.spec     10 May 2005 01:14:09 -0000      1.1291
+++ kernel-2.6.spec     10 May 2005 12:31:57 -0000
@@ -428,6 +428,7 @@
 Group: System Environment/Kernel
 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
+Provides: kernel-devel = %{rpmversion}-%{release}smp
 AutoReqProv: no
 Prereq: /usr/sbin/hardlink, /usr/bin/find

@@ -468,6 +469,7 @@
 AutoReqProv: no
 Provides: kernel-xen0-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xen0
+Provides: kernel-devel = %{rpmversion}-%{release}xen0
 Prereq: /usr/sbin/hardlink, /usr/bin/find

 %description xen0-devel
@@ -502,6 +504,7 @@
 AutoReqProv: no
 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
+Provides: kernel-devel = %{rpmversion}-%{release}xenU
 Prereq: /usr/sbin/hardlink, /usr/bin/find

 %description xenU-devel


Dave/Seth -- if this seems sane to you, let me know and I can commit it.

Comment 5 Jeremy Katz 2005-05-10 18:05:43 UTC
Changed the kernel spec and reverted the yum change.  This'll fix the
kernel-xen[0U]-devel too :-)

Comment 6 Jeremy Katz 2005-05-16 20:18:29 UTC
*** Bug 157730 has been marked as a duplicate of this bug. ***

Comment 7 Jef Spaleta 2005-05-24 14:11:25 UTC
Uhm.... 
I'm still seeing kernels-smp-devel being updated by yum in rawhide even as of
today. kernel-smp-devel 1341 updated 1340 and so on back in time since this bug
was put in the modified state. As far as I can tell nothing has changed. Did you
accidently revert the wrong yum change in comment #5?

-jef

Comment 8 Jeremy Katz 2005-05-24 14:37:34 UTC
*** Bug 158627 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2005-05-24 14:42:14 UTC
I see what's going on here...  looking at doing a generic fix for it in yum

Comment 10 Jeremy Katz 2005-05-24 14:57:15 UTC
yum wasn't matching provides against installonlypkgs -- fixed for yum-2.3.2-5
(and in upstream cvs)

Comment 11 Jef Spaleta 2005-08-26 01:52:29 UTC
kernel-smp-devel installs instead of updates for me, for awhile now. Closing the
bug as fixed.