Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155955

Summary: RFE: newer gamin for RHEL
Product: Red Hat Enterprise Linux 4 Reporter: Aleksey Nogin <aleksey>
Component: gaminAssignee: Alexander Larsson <alexl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: shillman
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: U4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-14 12:04:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 159226    

Description Aleksey Nogin 2005-04-26 02:21:19 UTC
Currently RHEL 4 has gamin-0.0.17-4. AFAIK, there were numerous bugs fixed in
gamin since 0.0.17 - any plans for an RHEL update? Thanks!

P.S. The reason I am asking is that our "omake" program that works correctly
under FC3, under RHEL4WS keeps dying when FAMNextEvent returns a "Connection
failure" error (but gam_server dose not crash, so I do not know what causes the
error). I do not want to spend time debugging this if an updated gamin is in the
works.

Comment 1 Suzanne Hillman 2005-04-26 16:12:33 UTC
Internal RFE bug #156006 entered; will be considered for future releases.

Comment 2 Daniel Veillard 2005-07-12 14:58:25 UTC
In progress, gamin-0.1.1-1.EL4 pushed,

Daniel

Comment 3 Subha Narasimhan 2006-04-09 19:21:58 UTC
I see a similar problem in my (daemon) application where the application is 
inexplicably not receiving dir creation events from the gam_server.
(in both gamin 0.0.17 and 0.1.3)

This seems to happen on a linux box that does not run the gnome session 
manager...

On box1, the gnome session manager has a number of apps that call the 
gam_server, so it (the gam_server) is always up for the application to hook 
onto

The application starts the gam_server on the box2 unlike box1 because the 
gnome desktop is not running.

And in this situation, the application does not recieve the dir creation 
events after opening the connection. This is the problem

However if I start the gam_server with a small monitor application BEFORE 
starting the application, it behaves normally.




Comment 4 Alexander Larsson 2006-08-14 12:04:17 UTC
This is updated in U2 and U4.