Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155923

Summary: modal dialogs should always take focus
Product: [Fedora] Fedora Reporter: Ray Strode [halfline] <rstrode>
Component: metacityAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-10 12:21:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 136450    

Description Ray Strode [halfline] 2005-04-25 19:49:18 UTC
Slowkeys pops up a modal dialog that pops up under other windows, so the user's
session appears to lock up.

Comment 1 Ray Strode [halfline] 2005-05-04 15:52:13 UTC
Focus stealing prevention is cool, but it shouldn't happen for modal dialogs
because the user will think their desktop has frozen.

Comment 2 Matthias Clasen 2005-05-05 14:46:29 UTC
I have described the issues we see in
http://bugzilla.gnome.org/show_bug.cgi?id=303136

Comment 3 Matthias Clasen 2005-05-10 12:21:25 UTC
A fix for this is now in rawhide.