Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155797

Summary: point the applet to satellite does not work
Product: Red Hat Network Reporter: Thorsten Scherf <tscherf>
Component: RHN/BackendAssignee: Mihai Ibanescu <mihai.ibanescu>
Status: CLOSED DUPLICATE QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: rhn370CC: rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-16 22:14:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thorsten Scherf 2005-04-23 12:52:55 UTC
Description of problem:
when configuring the rhn-applet on the client to use the satellite instead of
the upstream server it fails. the client was configuried like described in the
client-config manual. 


Version-Release number of selected component (if applicable):
rhn-satellite 3.7
rhn-applet-2.1.17-5
rhn-applet-actions-2.0.13-2


How reproducible:
always.

Steps to Reproduce:
1.setup the client
2.start rhn-applet
3.
  
Actual results:
applet does not work

Expected results:
working applet ;)

Additional info:
from the satellite server log:

/var/log/httpd/error_log:
Exception reported from file.rhel.homelinux.com
Time: Sat Apr 23 14:46:09 2005
Exception type exceptions.TypeError
Exception while handling function applet.poll_packages
Request object information:
URI: /APPLET
Remote Host: 192.168.0.13
Server Name: file.rhel.homelinux.com:443
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 376
        Host: file.rhel.homelinux.com:443
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 1.40 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 1.44)
        x-rhn-transport-capability: follow-redirects=1
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc
(version 1.40)
Extra information about this error:
Response sent back to the caller:
While running 'applet.poll_packages': caught
exceptions.TypeError : String '2005042217332' is not a YYYYMMDDHHMISS



Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 107, in call_function
    response = apply(func, params)
  File "/usr/share/rhn/server/handlers/applet/applet.py", line 155, in poll_packages
    ret = rhnCache.get(cache_key, last_channel_changed_ts)
  File "/usr/share/rhn/common/rhnCache.py", line 71, in get
    modified = timestamp(modified)
  File "/usr/share/rhn/common/rhnLib.py", line 58, in timestamp
    raise TypeError("String '%s' is not a YYYYMMDDHHMISS" % s)
TypeError: String '2005042217332' is not a YYYYMMDDHHMISS

Exception reported from file.rhel.homelinux.com
Time: Sat Apr 23 14:46:10 2005
Exception type exceptions.AttributeError
Exception while handling function handler
Request object information:
URI: /APPLET
Remote Host: 192.168.0.13
Server Name: file.rhel.homelinux.com:443
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 376
        Host: file.rhel.homelinux.com:443
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 1.40 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 1.44)
        x-rhn-transport-capability: follow-redirects=1
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc
(version 1.40)
Extra information about this error:
Unhandled exception type

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheServer.py", line 49, in __call__
    ret = f(req)
  File "/usr/share/rhn/server/apacheHandler.py", line 185, in handler
    ret = self._req_processor.process()
  File "/usr/share/rhn/server/apacheRequest.py", line 415, in process
    return self.call_function(method, params)
  File "/usr/share/rhn/server/apacheRequest.py", line 160, in call_function
    ret = self.response(response)
  File "/usr/share/rhn/server/apacheRequest.py", line 293, in response
    output.process(response)
  File "/usr/lib/python2.3/site-packages/rhn/transports.py", line 671, in process
    self.set_header("Content-Length", len(self.data))
AttributeError: Fault instance has no attribute '__len__'

/var/log/rhn/:
2005/04/23 14:45:06 +02:00 10754 192.168.0.13:
applet/applet.poll_packages('4Desktop', 'i686', '20050421051119',
'aee6d58e-9e46-11d9-8410-00055da333cd')
2005/04/23 14:46:07 +02:00 10743 192.168.0.13:
applet/applet.poll_packages('4Desktop', 'i686', '20050421051119',
'aee6d58e-9e46-11d9-8410-00055da333cd')
2005/04/23 14:46:09 +02:00 10750 192.168.0.13:
applet/applet.poll_packages('4Desktop', 'i686', '20050421051119',
'aee6d58e-9e46-11d9-8410-00055da333cd')

Comment 1 Thorsten Scherf 2005-05-16 22:14:58 UTC

*** This bug has been marked as a duplicate of 151812 ***