Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155767

Summary: konquest uses : as value of 10 for integers
Product: [Fedora] Fedora Reporter: Paul Dickson <paul>
Component: kdegamesAssignee: Ngo Than <than>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-27 19:43:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Dickson 2005-04-22 20:47:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050420 Firefox/1.0+

Description of problem:
In the game konquest, each planet produces a number of ships each turn.  The total is displayed when you mouse-over an owned planet.  Some times the total will have a : (colon) in the units digit (eg 13:).  The value of this colon is apparently 10, so 13: is 140.

This does not happen happen every time.  On a planet which increase the total by 10 each turn, every other turn will have a : in the total (in the units position).

This does not occur in the FC3 version of the game (kdegames-3.3.1-1).

This is a bad int-to-text routine somewhere (compiler?).

Version-Release number of selected component (if applicable):
kdegames-3.4.0-1

How reproducible:
Always

Steps to Reproduce:
1. Start new game.
2. Mouse-over your planet to get total.
3. Click "End Turn".
4. Perform 2 & 3 until turn 13.
5. Total should be 130, but 12: is displayed.
  

Actual Results:  On turn 13, the total should be 130, but 12: is displayed (if you did not move any ships).

Additional info:

With any luck, this bug is in konquest rather than the compiler.

Comment 1 Paul Dickson 2005-04-27 19:43:08 UTC

*** This bug has been marked as a duplicate of 155757 ***