Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155740

Summary: MOZ_DISABLE_PANGO doesn't work on Thunderbird
Product: [Fedora] Fedora Reporter: Behnam [:ZWNJ] Esfahbod <bugs+behnam>
Component: thunderbirdAssignee: Christopher Aillon <caillon>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: blizzard, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://bamdad.org/~behnam/persian/mozilla/pango/test_03.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-13 21:00:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 136451, 136452    

Description Behnam [:ZWNJ] Esfahbod 2005-04-22 17:43:48 UTC
Description of problem:
MOZ_DISAIBLE_PANGO should turn off pango rendering on mozilla-based
applications.  But Thunderbird doesn't understand it.


Version-Release number of selected component (if applicable):
version 1.0.2-1.3.2 (20050324)


How reproducible:
Always.

Steps to Reproduce:
1. Run Thunderbird and open the URL.
You will see that characters of last line arranged LtR.
2. Set MOZ_DISABLE_PANGO=1, run thunderbird and open the URL again.

Actual results:
It's same as the first try.

Expected results:
Last line should be like other lines.

Comment 1 Warren Togami 2005-05-12 08:34:42 UTC
Hmm confirmed in FC4, we should really fix this because some users (like Arabic
or Hebrew?) need to disable pango in order to use the software.

Comment 2 Christopher Aillon 2005-05-13 21:00:45 UTC
Fixed in rawhide.

Comment 3 Behnam [:ZWNJ] Esfahbod 2005-05-14 01:51:00 UTC
Thanks Chris.

But, wont there be any update for FC3?

Comment 4 Christopher Aillon 2005-05-14 05:11:56 UTC
Yes it will be in the next update for FC3.