Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155613

Summary: suspend scripts
Product: [Fedora] Fedora Reporter: David Zeuthen <davidz>
Component: pm-utilsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bnocera, markmc, mclasen, petrosyan, pjones, rvokal
Target Milestone: ---Keywords: FutureFeature, Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.02-1 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-05 05:31:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 121061    
Attachments:
Description Flags
tarball with files none

Description David Zeuthen 2005-04-21 20:00:06 UTC
Description of problem:

Will attach tarball with suspend scripts that users on the console may invoke to
begin with. Should be good to include thus far; things we might want to improve
later on:

 1) autodetecting radeons and using radeontool (pjones, any ideas?)
 2) handling non-NM networking

The attached tarballs contains

-rw-r--r-- root/root      1182 2005-04-21 14:45:09 etc/pm-suspend.conf
lrwxrwxrwx root/root         0 2005-04-21 14:48:23 usr/bin/pm-suspend ->
consolehelper
-rwxr-xr-x root/root      3530 2005-04-21 14:59:21 usr/sbin/pm-suspend
-rw-r--r-- root/root         0 2005-04-21 14:55:29
etc/security/console.apps/pm-suspend

Comments?

Comment 1 David Zeuthen 2005-04-21 20:00:10 UTC
Created attachment 113486 [details]
tarball with files

Comment 2 David Zeuthen 2005-04-29 15:12:37 UTC
*** Bug 143397 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Fenzi 2005-04-29 17:55:28 UTC
Another (perhaps more complicated) solution is available in the suspend2 
hibernate script: 

http://suspend2.net/downloads/all/hibernate-1.06-1.src.rpm

Which can suspend using suspend2, suspend1, S3 (suspend to ram), etc. 
It also can use radeontool, vbetool, start a dummy X server after resume, change
to a text console, unload/reload modules, up/down interfaces, etc. 



Comment 4 David Zeuthen 2005-06-16 02:36:23 UTC
So it looks like pjones got the whitelist in the kernel so userspace don't have
to do tricks that the drivers should (however something needs to load radeonfb
driver though). 

With that in mind, can we go ahead and add the pm-suspend stuff? We need this to
include goodness like gnome-power-manager... I'm sure we want to change things
in pm-suspend before FC5 (perhaps just make it call a suspend2 scripts, who
knows) but we need to start somewhere.

Comment 5 Bill Nottingham 2005-07-05 05:31:16 UTC
A variant added in 0.02-1. Significant lack of configuration, *intentionally*. :)