Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155399

Summary: [RFE] add grub to rescue image
Product: [Fedora] Fedora Reporter: Alexandre Oliva <oliva>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: tedkaz
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-01-18 16:37:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexandre Oliva 2005-04-19 22:30:55 UTC
I've just mentioned in bug 105598 how I ended up missing grub for a rescue
session (/ and /boot were in a raid 1 device that became degraded), and how I
wished the rescue image contained grub itself, instead of relying on grub from
the installed image.

Comment 1 Ted Kaczmarek 2005-09-20 17:07:00 UTC
How do you even get grub-install to work like this?
I am stymied by this, grub-install  want's the stage1 file in /usr which doesn't
haven't and can't be created on RO file system.

Comment 2 Alexandre Oliva 2006-01-13 15:42:01 UTC
Well, it works for me, but I didn't try grub-install, only the grub binary
itself.  Anyhow, the rescuecd *still* doesn't contain grub, so if things get
messed up and you happen to be trying to recover from the loss of a disk
containing raid members, you're just screwed.  I really hope Red Hat Enterprise
Linux is better in this regard.

Comment 4 David Cantrell 2006-01-18 16:37:59 UTC
Done, grub added to i386 rescue image.