Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155232

Summary: strange error: conflicting types
Product: [Fedora] Fedora Reporter: Neal Becker <ndbecker2>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-18 14:10:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
preprocessed none

Description Neal Becker 2005-04-18 11:44:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
In file included from Src/libnumarraymodule.c:3638: 
/usr/include/fenv.h: In function `int_overflow_error': 
/usr/include/fenv.h:96: error: conflicting types for 'fegetenv' 
/usr/include/fenv.h:96: error: previous declaration of 'fegetenv' was here 
/usr/include/fenv.h:101: error: conflicting types for 'feholdexcept' 
/usr/include/fenv.h:101: error: previous declaration of 'feholdexcept' was 
here 
/usr/include/fenv.h:105: error: conflicting types for 'fesetenv' 
/usr/include/fenv.h:105: error: previous declaration of 'fesetenv' was here 
/usr/include/fenv.h:110: error: conflicting types for 'feupdateenv' 
/usr/include/fenv.h:110: error: previous declaration of 'feupdateenv' was here 
 

Version-Release number of selected component (if applicable):
gcc-3.4.3-22.fc3

How reproducible:
Always

Steps to Reproduce:
1.gcc 
2. 
3. 
   

Additional info:

Comment 1 Neal Becker 2005-04-18 11:45:24 UTC
Created attachment 113319 [details]
preprocessed

Comment 2 Jakub Jelinek 2005-04-18 14:10:33 UTC

*** This bug has been marked as a duplicate of 154781 ***