Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 155097

Summary: No ieee1394/firewire HDD after plug in the disk
Product: [Fedora] Fedora Reporter: Frank Büttner <bugzilla>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: jarod, pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-03 21:37:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Frank Büttner 2005-04-16 07:26:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.6) Gecko/20050319

Description of problem:
When i plug in my firewire disk it will not seen by the kernel.
Bevor plug in the modues ohci1394 and sbp2 are loaded.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. load the 2 modules
2. Plug in the HDD
  

Actual Results:  nothink happends. But a error in /var/log/messages

Expected Results:  an entry in /proc/partions and in /var/log/messages about my disk.

Additional info:

This get I after Plug in the disk:
kernel: ieee1394: Error parsing configrom for node 0-00:1023

Comment 1 Dave Jones 2005-07-15 19:18:18 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Frank Büttner 2005-07-16 09:57:54 UTC
So I have update to the new kernel. But the problem is the same.:(

Comment 3 Andreas Sikkema 2005-10-03 08:56:53 UTC
I think I'm having similar problems trying to get a Maxtor Ontrack II 300GB ext
harddisk connected to my laptop.

Current kernel = 2.6.12-1.1378_FC3smp
Running FC3 on a Dell Inspiron 5150 P4 3.0 GHz HT enabled

lspci reports:00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to AGP
Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go 5200]
(rev a1)
02:01.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
02:04.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus Controller
(rev 02)
02:04.1 FireWire (IEEE 1394): Texas Instruments PCI4510 IEEE-1394 Controller

I removed all Firewire related modules from memory, then attached the harddisk
to the laptop. The I modprobed sbp2. This resulted in the following lines in
/var/log/messages:

Sep 29 22:36:30 delphic kernel: ohci1394: $Rev: 1250 $ Ben Collins
<bcollins@debian.org>
Sep 29 22:36:30 delphic kernel: ACPI: PCI Interrupt 0000:02:04.1[A] -> GSI 16
(level, low) -> IRQ 177
Sep 29 22:36:30 delphic kernel: ohci1394: fw-host0: OHCI-1394 1.1 (PCI):
IRQ=[177]  MMIO=[faffc800-faffcfff]  Max Packet=[2048]
Sep 29 22:36:30 delphic ieee1394.agent[6172]: ... no drivers for IEEE1394
product 0x/0x/0x
Sep 29 22:36:31 delphic ieee1394.agent[6211]: ... no drivers for IEEE1394
product 0x/0x/0x
Sep 29 22:36:31 delphic ieee1394.agent[6194]: ... no drivers for IEEE1394
product 0x/0x/0x
Sep 29 22:36:32 delphic ieee1394.agent[6239]: ... no drivers for IEEE1394
product 0x/0x/0x
Sep 29 22:36:58 delphic kernel: ieee1394: Error parsing configrom for node 0-01:1023
Sep 29 22:36:58 delphic kernel: ieee1394: Error parsing configrom for node 0-00:1023

Another PC also running FC3 has no problems with the ahrddisk, but itis using a
different firewire controller.

Comment 4 Frank Büttner 2005-10-03 09:07:36 UTC
I habe buy now an Maxtor One touch II and this will work without Problems. The
disk whitch has the problem use the profilic bridge. This bridge have some
problems with it firewire part.:( My firecontroller is an NEC.

Comment 5 Dave Jones 2005-10-03 21:37:09 UTC
http://www.google.com/search?hl=en&lr=&q=prolific+firmware+update+ieee1394&btnG=Search
turns up a bunch of reports of users having problems with this chip, along with
some success reports after they updated their firmware.

This sounds like a hardware problem that we can't really work around, so I'm
going to CLOSE->CANTFIX this bug.


Comment 6 Jarod Wilson 2008-03-07 21:57:05 UTC
Accidentally stumbled upon this bug searching for other stuff... We actually
finally play nice with Prolific PL-3507 devices in the new firewire stack as of
a few days ago (rawhide or f8 updates-testing kernel as of today required). :)