Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 154891

Summary: starting GUI on a running Gulm cluster doesn't work
Product: [Retired] Red Hat Cluster Suite Reporter: Corey Marthaler <cmarthal>
Component: redhat-config-clusterAssignee: Jim Parsons <jparsons>
Status: CLOSED NEXTRELEASE QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-28 22:15:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Corey Marthaler 2005-04-14 18:30:19 UTC
Description of problem:
I thought that there was already a bug open for this but I didn't find one...

When first starting the GUI (on a running gulm cluster), it causes an error
because it can't talk to cman and then backtraces and dies.

Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 407, in ?
    runFullGUI()
  File "/usr/sbin/system-config-cluster", line 390, in runFullGUI
    baseapp = basecluster(glade_xml, app)
  File "/usr/sbin/system-config-cluster", line 124, in __init__
    self.mgmttab = MgmtTab(glade_xml, self.model_builder)
  File "/usr/share/system-config-cluster/MgmtTab.py", line 116, in __init__
    self.prep_service_tree()
  File "/usr/share/system-config-cluster/MgmtTab.py", line 165, in prep_service_tree
    if len(services) == 0:
TypeError: len() of unsized object

Comment 1 Jim Parsons 2005-04-28 21:36:34 UTC
Fixed in 0.9.43

Comment 2 Corey Marthaler 2005-04-28 22:15:39 UTC
fix verified in -43.