Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 154548

Summary: grub installs in MBR even if pointed to another partition
Product: [Fedora] Fedora Reporter: Gene Czarcinski <gczarcinski>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-02 03:57:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gene Czarcinski 2005-04-12 15:52:39 UTC
Description of problem:
This was reported in FC4T1 but then claimed as "fixed in rawhide" ... well, if
it was fixed it is back.

Ref: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=151204

151204 was reported against grub but this looks to me more like and anaconda bug
-- grub works properly but is being passed bad info.

System: ASUS SK8V Opteron doing everything install of i386 system  Specified to
install grub into the root ("/") partition (includes /boot).  Actually installed
into the MBR.

Fixup is pretty easy to do using the rescueCD but still a pain and should not be
happening.

Comment 1 Matthew Lenz 2005-04-29 17:00:23 UTC
I didn't have the problem of it installing to the MBR (when telling it to
install to the boot sector of the partition).  I had the problem that it simply
didn't install grub at all when telling it to install to the boot sector of the
partition.

after using grub from the mbr (another distro manages my mbr thats why fedora
was asked to install grub to its own partition) and booting fedora a simple
grub-install (hdx,x) worked like a charm.

Also the placement of the advanced options for grub is very nonintuitive.  why
not just put it under the button where you choose whether grub should be
installed or not?  Currently you have to say 'install grub to mbr' and then
check advanced options to make the change on the next screen.

Comment 2 Warren Togami 2005-05-02 03:57:29 UTC

*** This bug has been marked as a duplicate of 151204 ***