Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 154546

Summary: Clicking a fence device object causes Traceback error
Product: [Retired] Red Hat Cluster Suite Reporter: Paul Kennedy <pkennedy>
Component: redhat-config-clusterAssignee: Jim Parsons <jparsons>
Status: CLOSED NEXTRELEASE QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: adstrong, cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-29 20:42:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Kennedy 2005-04-12 15:48:41 UTC
Description of problem:
At the navigation tree, clicking a fence device under "Fence Devices" causes a
Traceback error. Captured message is in "Actual Results" that follows.

Version-Release number of selected component (if applicable):
0.9.26

How reproducible:


Steps to Reproduce:
1. Start system-config-cluster.
2. Click a fence device under the "Fence Devices" object.
3. Observe traceback error message at command line prompt.

  
Actual results:
[root@tng3-4 root]# system-config-cluster
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTab.py", line 148, in
on_tree_selection_changed
    self.prop_renderer.render_to_layout_area(obj.getProperties(),
obj.getName(),type)
  File "/usr/share/system-config-cluster/FenceDevice.py", line 34, in getProperties
    stringbuf = stringbuf + "<span><b>" + NAME + ": " + "</b>" + VALUE + "\n</span>"
TypeError: coercing to Unicode: need string or buffer, NoneType found


Expected results:
No error message

Additional info:
To make the problem occur after clicking the fence device, click any other
object in the navigation tree, then click the fence device again.

Comment 1 Corey Marthaler 2005-04-21 18:49:09 UTC
FWIW, I can not reproduce this in 0.9.33-1.0

Comment 2 Paul Kennedy 2005-04-21 19:07:03 UTC
I am running at 0.9.33-1.0 also and see the same problem. Traceback output:

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTab.py", line 153, in
on_tree_selection_changed
    self.prop_renderer.render_to_layout_area(obj.getProperties(),
obj.getName(),type)
  File "/usr/share/system-config-cluster/FenceDevice.py", line 34, in getProperties
    stringbuf = stringbuf + "<span><b>" + NAME + ": " + "</b>" + VALUE + "\n</span>"
TypeError: coercing to Unicode: need string or buffer, NoneType found


Comment 3 Jim Parsons 2005-04-25 23:18:55 UTC
This error is/was caused by a bad config file attr name. This possible error is
now trapped for.

Fixed in 0.9.34-1.0

Comment 4 Corey Marthaler 2005-04-29 20:42:41 UTC
I have been unable to reproduce this, if seen again by others it can be reopened.