Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 154033

Summary: htmlview -remote option shows an unexpected page with a strange error message
Product: Red Hat Enterprise Linux 4 Reporter: Noriko Hosoi <nhosoi>
Component: htmlviewAssignee: Christopher Aillon <caillon>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: nkinder, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-29 21:26:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Noriko Hosoi 2005-04-06 17:57:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
When no browser is up, trying to open an URL using htmlview brings up an unexpected page and it does not return.

Please note that RHEL3 htmlview returns immediately with this error:
    Error: No running window found.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make sure no browser is launched
2. run 'htmlview -remote "openURL(http://www.redhat.com)"'

  

Actual Results:  1. it returns an error:
   /usr/bin/htmlview: line 75: [: -remote: binary operator expected
2. it brings up a default browser with the default initial page (note: not the page specified in the original command line "http://www.redhat.com")

Expected Results:  Either of these:
1) as being done on RHEL3 htmlview, return immediately with an appropriate error
or
2) display the specified URL

Additional info:

Comment 1 Noriko Hosoi 2005-04-06 18:04:51 UTC
FYI:
rpm -q htmlview
htmlview-3.0.0-8


Comment 2 Warren Togami 2005-04-25 07:28:01 UTC
Where did you hear about the "-remote" option of htmlview?  htmlview since
version 2.x contained the following.

# ignore legacy cruft
if [ "$1" == "--remote" ]; then
        shift
elif [ "$1" == "--local" ]; then
        shift
fi

AFAIK "-remote" was never supported, and it would be passed to a browser and
that is the reason why you are seeing strange effects by using it.  --remote
would be ignored these days because X remote capable browsers handle it in their
own launch scripts automatically.

This bug should be closed NOTABUG, however if we have bad documentation
somewhere that mentions either -remote or --remote it should be corrected. 
Where did you hear about this option?

Comment 3 Nathan Kinder 2005-04-25 16:11:36 UTC
We are not referring to the "--remote" option of htmlview, but Mozilla's
"-remote" option.  Mozilla's "-remote" option allows you to connect to a running
browser process instead of starting a new one.  You can find out about it here:
http://www.mozilla.org/unix/remote.html

Comment 4 Nathan Kinder 2005-04-25 18:39:27 UTC
I should also mention that the problem seems to be with the mimic_gnome_open
function of htmlview.  It seems to mess up the options that should just be
getting passed through to the browser.  This worked fine in htmlview 2.x, which
didn't have the mimic_gnome_open functionality.

Comment 5 Warren Togami 2005-04-25 21:30:16 UTC
What I'm saying is that passing -remote is totally not necessary because the
browser launcher itself is supposed to handle exactly that behavior
automatically.  That is not the case?

Comment 6 Warren Togami 2005-05-12 08:57:48 UTC
I added '-remote' as a parameter that FC4 htmlview will ignore.

htmlview is not meant to pass additional options to browsers.  One shouldn't
expect it to work either, because htmlview can be used to launch *any* browser
which is configured in Preferred Applications, which could be konqueror, opera
or even elinks.

Proposing this for RHEL4U2 mainly due to the fix in Bug #92335 which is more
important.

Justification:
1) htmlview changes since RHEL4 are trivial and obviously correct.
2) Fixes from Bug #92335 correct a clearly wrong and confusing behavior.

Comment 8 Noriko Hosoi 2005-07-29 21:22:47 UTC
We worked around not to use '-remote' in Directory Server 7.1 (on RHEL3 U4 and
RHEL4).
We stop using the utility in the future version.
Thank you for your support.

To close this bug, to which value I should change the status?