Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 153984

Summary: Plugging my camera doesn't launch anything
Product: [Fedora] Fedora Reporter: Daniel Malmgren <dm>
Component: gnome-volume-managerAssignee: John (J5) Palmieri <johnp>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jkeck
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-06 13:07:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Daniel Malmgren 2005-04-06 12:53:33 UTC
Description of problem:
I've set gnome-volume-properties to launch a program when a digital camera is
connected. It doesn't.

Version-Release number of selected component (if applicable):
hal-0.5.0.cvs20050404b-2
gnome-volume-manager-1.3.1-1

How reproducible:
100%

Steps to Reproduce:
1. Connect my usb camera
  
Actual results:
The following from gnome-volume-manager:
manager.c/798: New Device:
/org/freedesktop/Hal/devices/usb_device_4cb_112_Y_393_____020913WFC00001022379
manager.c/798: New Device:
/org/freedesktop/Hal/devices/usb_device_4cb_112_Y_393_____020913WFC00001022379_if0
libhal.c 1058 : wrong reply from hald.  Expecting an array.
libhal.c 1058 : wrong reply from hald.  Expecting an array.
manager.c/798: New Device:
/org/freedesktop/Hal/devices/usb_device_4cb_112_Y_393_____020913WFC00001022379_if0_scsi_ho
st
manager.c/798: New Device:
/org/freedesktop/Hal/devices/usb_device_4cb_112_Y_393_____020913WFC00001022379_if0_scsi_ho
st_scsi_device_lun0
manager.c/798: New Device: /org/freedesktop/Hal/devices/storage_model_USB_DRIVEUNIT
manager.c/798: New Device: /org/freedesktop/Hal/devices/volume_part1_size_65507840
manager.c/838: Changed: /dev/sda1
manager.c/775: Added: /dev/sda1
manager.c/923: Mounted: /org/freedesktop/Hal/devices/volume_part1_size_65507840
manager.c/313: Photos detected: /mnt/fujifilm/dcim

Expected results:
I expect my program to be started for transferring images to the computer.

Additional info:
I first filed this under a hal bug (#150985), According to davidz it's a
gnome-volume-manager bug.
After plugging the camera, g-v-m consumes all available cpu power until killed.
I don't think it does anything useful with it though :-/

Comment 1 Daniel Malmgren 2005-04-06 12:55:10 UTC
Oh, forgot to mention: It has worked before. Not quite sure when it stopped
working though. Some time during march I think...

Comment 2 John (J5) Palmieri 2005-04-06 13:07:05 UTC

*** This bug has been marked as a duplicate of 151960 ***