Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1538046

Summary: More info on foreman-maintain user name and password
Product: Red Hat Satellite 6 Reporter: Stephen Wadeley <swadeley>
Component: Docs Upgrading and Updating Red Hat SatelliteAssignee: Vlada Grosu <vgrosu>
Status: CLOSED NEXTRELEASE QA Contact: Stephen Wadeley <swadeley>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.3.0CC: adahms, nkathole
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-16 09:59:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1517871    

Description Stephen Wadeley 2018-01-24 10:58:40 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3-beta/html/upgrading_and_updating_red_hat_satellite/upgrading_red_hat_satellite
Section Number and Name: 

Chapter 2. Upgrading Red Hat Satellite

Describe the issue: 

This is too vague:
foreman-maintain with the correct username and password

Suggestions for improvement: 

Delete this whole line:
This will configure foreman-maintain with the correct username and password

add below: You will be prompted for the hammer admin user credentials. They will be configured in /etc/foreman-maintain/foreman-maintain-hammer.yml

Comment 1 Stephen Wadeley 2018-01-24 11:00:18 UTC
Hello Nikhil

Can you confirm all in comment 0 is accurate


Thank you

Comment 2 Nikhil Kathole 2018-01-24 11:52:49 UTC
Hi Stephen,

Just making a small change. Let's make it as 

"This will configure foreman-maintain with hammer credentials. They will be configured in /etc/foreman-maintain/foreman-maintain-hammer.yml."

Because it will prompt when there is no default hammer configuration file /root/.hammer/cli.modules.d/foreman.yml (like in satellite 6.2 ), else it will configure foreman-maintain with hammer credentials using default file (like in satellite 6.3). 

================================================================================
Setup hammer:
Using defaults from /root/.hammer/cli.modules.d/foreman.yml
New settings saved into /etc/foreman-maintain/foreman-maintain-hammer.yml
                                                                      [OK]
--------------------------------------------------------------------------------

Comment 3 Andrew Dahms 2018-01-25 00:28:46 UTC
Assigning to Vlada for review.

Comment 4 Vlada Grosu 2018-01-25 11:31:37 UTC
Thank you, Andrew!

I'll start working on it.