Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 153778

Summary: QA review of perl-Config-Record-1.1.0
Product: [Fedora] Fedora Reporter: Dennis Gregorovic <dgregor>
Component: perl-Config-RecordAssignee: Dennis Gregorovic <dgregor>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jose.p.oliveira.oss
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://gregorovic.net/fc3-autobuild-rpms/perl-Config-Record-1.1.0-1.src.rpm
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-15 19:52:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dennis Gregorovic 2005-04-05 20:04:06 UTC
Config::Record provides a module for loading configuration
records. It supports scalar, array and hash parameters nested
to an arbitrary depth.

Comment 1 Jose Pedro Oliveira 2005-04-06 18:22:55 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

PUBLISH++

MD5SUMS:
1d5749b59e78af01a613f1f8cf109efb  perl-Config-Record-1.1.0-1.src.rpm

ea88d88c49e57a8999ae6ca0cee8c76e  Config-Record-1.1.0.tar.gz
dcae2633ca28f2c32160604cb4747637  perl-Config-Record.spec

Sources:
* Config-Record-1.1.0.tar.gz: MD5 digest checked against the CPAN tarball


Good:
* Package name follows standard
* SRPM signature verified: db5b842b
* Specfile looks good
* URL and Sources/Patches url: OK
* License verified: GPL (file LICENSE)
* Requirements and build requirements: OK
* perl(:MODULE_COMPAT_xxx): present
* perl vendor libs: supported
* File permissions: OK
* Builds without problems in FC3
* (Un)installs without problems in FC3
* No tickets opened in RT
  (http://rt.cpan.org/NoAuth/Bugs.html?Dist=Config-Record)


Additional notes:
* Module is not covered by the Phalanx100
  (http://qa.perl.org/phalanx/100/)
* If you are only targeting FC >= 2 you can drop the conditional define
  (first specfile line)
* If you are only targetting perl >= 5.8.0 you can drop the Test::More
  build requirement. Test::More is a perl core module since 5.8.0
  (and 5.6.2).  You may also consider installing perl-Module-CoreList.


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFCVCjWl0metZG9hRsRAn9UAKDmFZR6DbbF9IL9VeLMP0bBJIcAxgCg0Fah
Rym8tebneQbakY6xrzf806A=
=rEbu
-----END PGP SIGNATURE-----

Comment 2 Dennis Gregorovic 2005-04-06 19:09:22 UTC
Jose,

Thank you for the review.

Also, thank you for the other tips.  The list of 'Good' will be a helpful
checklist for the next review I do.  I didn't know about the Phalanx100 or
perl-Module-CoreList.

Cheers
-- Dennis

Comment 3 Jose Pedro Oliveira 2005-04-06 19:47:36 UTC
Dennis,

Feel free to import the package to CVS and request the FC-3 branch creation and
 build.

jpo

PS - You also have CPANTS Kwalitee :)
     http://cpants.dev.zsi.at/
     http://cpants.dev.zsi.at/kwalitee.html
PS2 - See also perl-pmtools. The scripts pmvers, pmpath, and pmexp
      are my favorites.


Comment 4 Jose Pedro Oliveira 2005-04-15 19:52:18 UTC
Dennis,

Closing this ticket.

/jpo

PS - Have you added a building request for this package?
See http://fedoraproject.org/wiki/Extras_2fFC3Status.

Comment 5 Dennis Gregorovic 2005-04-15 19:57:21 UTC
Hmmm... I could have sworn that I put in a build request.  However, I get an
error trying to view the history of that page, so I can't say for sure.  Anyway,
I'll put in another request.