Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 153249

Summary: Won't uninstall
Product: Red Hat Enterprise Linux 3 Reporter: Tim Nelson <tim.nelson>
Component: docbook-style-dssslAssignee: Ondrej Vasik <ovasik>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-21 07:36:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tim Nelson 2005-04-04 00:57:42 UTC
Description of problem:
The package won't uninstall due to the preun script failing.  

Version-Release number of selected component (if applicable):
docbook-style-dsssl-1.76-8

How reproducible:
Every time

Steps to Reproduce:
1. up2date docbook-style-dsssl
2. rpm -ev docbook-style-dsssl
  
Actual results:
error: %preun(docbook-style-dsssl-1.76-8) scriptlet failed, exit status 127

Expected results:
None visible (but package no longer installed)

Additional info:
I have a suspicion that it may require some other piece of software to be able
to uninstall (which I may already have removed).  I get given machines with
Redhat Enterprise preinstalled, and have to uninstall software we don't need. 
Is the preun script stored somewhere I can access it so that I can do some
further debugging?

Comment 1 Tim Waugh 2005-04-04 10:09:38 UTC
'rpm -q --scripts docbook-style-dsssl' shows you the package scriptlets.

The %preun scriptlet needs /usr/bin/install-catalog to be installed, and there
is a PreReq tag in the RPM to require the correct package (sgml-common).

Is sgml-common installed at the time of the removal of docbook-style-dsssl?

Comment 2 Tim Nelson 2005-04-05 07:10:18 UTC
I think it was originally.  If I install openjade and sgml-common, I get the
following results:
--------------------------------
# rpm -ev docbook-style-dsssl sgml-common openjade docbook-dtds xml-common
warning: /usr/share/sgml/docbook/xmlcatalog saved as
/usr/share/sgml/docbook/xmlcatalog.rpmsave
cat: /etc/sgml/catalog: No such file or directory
cat: /etc/sgml/catalog: No such file or directory
/var/tmp/rpm-tmp.68306: line 132: [: : integer expression expected
error: %preun(docbook-style-dsssl-1.76-8) scriptlet failed, exit status 127
--------------------------------
I installed them again, and then removed them in a sensible order (one at a
time), and it seems that everything worked except docbook-dtds, which gave the
error:
--------------------------------
# rpm -ev docbook-dtds
cat: /etc/sgml/catalog: No such file or directory
cat: /etc/sgml/catalog: No such file or directory
/var/tmp/rpm-tmp.95848: line 132: [: : integer expression expected
--------------------------------
The package went away, so I'm not complaining, but I mention this for your
information; you may want to open another with the errors mentioned.  I do also
wonder why the docbook-style-dsssl package fails to remove when done as part of
a group, but works if you remove it by itself with the removal prerequisites
installed.  I'm sure I'll run into the problem again sometime, and was wondering
if you have any ideas on this.  

Thanks,

Comment 3 Tim Waugh 2005-04-06 10:39:57 UTC
Those scriptlets are all a bit "delicate". :-(

Comment 4 Ondrej Vasik 2007-05-21 07:36:09 UTC
Closing as WONTFIX because there is no scheduled RHEL3.10(already missed 3.9
deadlines) release and package went away ("just cosmetic problem"). If still
occuring in RHEL5, you can open another ticket.