Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 153098

Summary: rhnpush --new_cache should be --new-cache
Product: Red Hat Network Reporter: John Wregglesworth <wregglej>
Component: RHN/BackendAssignee: John Wregglesworth <wregglej>
Status: CLOSED CURRENTRELEASE QA Contact: Max Spevack <mspevack>
Severity: medium Docs Contact:
Priority: medium    
Version: rhn370CC: mihai.ibanescu, rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHN 4.0.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-01 02:22:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Wregglesworth 2005-04-01 15:34:53 UTC
Description of problem: One of the options for rhnpush is --new_cache, but it
should be named --new-cache because _'s in options are annoying. This should be
an easy, one line change.

Comment 1 John Wregglesworth 2005-05-09 20:50:06 UTC
Test Plan:

o Use rhnpush to upload a package into a channel while without using the
--new-cache option. This will cause rhnpush to prompt you for your username and
password whick will be cached so you won't have to enter them the next time you
run rhnpush.

o Use rhnpush to upload a package into a channel again, still without
--new-cache.  As long as the cache hasn't expired (which takes 5 minutes by
default) you shouldn't be prompted for your username and password.

o Run rhnpush a third time, this time WITH --new-cache. This time you should be
prompted for your username and password because you included --new-cache.



Comment 2 Max Spevack 2005-08-03 20:57:03 UTC
PROD_READY