Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 152967

Summary: sdiff: subsidiary program $EDITOR failed
Product: Red Hat Enterprise Linux 3 Reporter: Rangan Chidambara Kuttalam Pillai <rchidamb>
Component: diffutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: low Docs Contact:
Priority: medium    
Version: 3.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 2.8.1-15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-06 15:37:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Rangan Chidambara Kuttalam Pillai 2005-03-31 14:57:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.4) Gecko/20050318 Red Hat/1.4.4-1.3.5

Description of problem:
sdiff shows the following error while making changes using the editor.

sdiff: subsidiary program `$EDITOR` failed


Version-Release number of selected component (if applicable):
diffutils-2.8.1-8

How reproducible:
Always

Steps to Reproduce:
1.echo hello >a; echo bye >b 
2.sdiff -o new a b 
3.Then enter 'eb' at % prompt.  This will bring up $EDITOR. 
4.Save, quit. 


Actual Results:  sdiff displays the following error.

sdiff: subsidiary program `$EDITOR` failed

Expected Results:  No error messages.

Additional info:

This bug has been already reported in gnu mailing list.

http://lists.gnu.org/archive/html/bug-gnu-utils/2003-01/msg00121.html 

Also a patch available at the URL
I tested the patch locally and it seem to resolve the problem.

Comment 1 Tim Waugh 2005-03-31 15:01:11 UTC
*** Bug 152968 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2005-04-06 15:37:39 UTC
That patch is wrong, but the correct patch has been applied now.  Thanks for the
report.