Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1528

Summary: Static routes to host does not work on 2.2 kernel
Product: [Retired] Red Hat Linux Reporter: Jan "Yenya" Kasprzak <kas>
Component: linuxconfAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: jack, juergen.klotz, kas
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-24 17:06:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jan "Yenya" Kasprzak 1999-03-16 14:57:04 UTC
When you enter the static host route to the linuxconf,
the ifup-routes tries to add this route using

route `linuxconf --hint routing <interface>`,

which expands to

route add -host <addr> gw <addr> netmask 255.255.255.255,

which the "route" command (from the updates/5.2/2.2-kernel)
does not like. The "linuxconf --hint routing eth0" should
print "add -host <addr> gw <addr>" for host static routes
(without the "netmask <netmask>").

Comment 1 Bill Nottingham 1999-03-16 21:44:59 UTC
*** Bug 1531 has been marked as a duplicate of this bug. ***

When you enter the static host route to the linuxconf,
the ifup-routes tries to add this route using

route `linuxconf --hint routing <interface>`,

which expands to

route add -host <addr> gw <addr> netmask 255.255.255.255,

which the "route" command (from the updates/5.2/2.2-kernel)
does not like. The "linuxconf --hint routing eth0" should
print "add -host <addr> gw <addr>" for host static routes
(without the "netmask <netmask>").

Comment 2 Michael K. Johnson 1999-03-23 01:02:59 UTC
Added Jacques to the CC list so that he can look into the problem.

Comment 3 Michael K. Johnson 1999-03-24 17:06:59 UTC
This appears to be fixed in linuxconf 1.14

------- Email Received From  Jacques Gelinas <jack@solucorp.qc.ca> 03/26/99 11:51 -------

Comment 4 Michael K. Johnson 1999-04-01 20:41:59 UTC
*** Bug 726 has been marked as a duplicate of this bug. ***

when entering a host-route with netmask 255.255.255.255
route claims somthing like "netmask 00000000" not allowed
for host-route!

adding the host without specifying the netmask works pretty
well, but I want to use linuxconf to do this kinda stuff
and
    "linuxconf --hint routing eth1"
ouputs something like
    "add -host myhost gw mygate netmask 255.255.255.255".



------- Additional Comments From Juergen.Klotz@nbg6.siemens.de  01/08/99 04:28 -------
I forgot, it's the Intel version

------- Additional Comments From dkl@redhat.com  01/18/99 14:43 -------
Can you send some more details of your routing table.  I am unable to
replicate the problem in the test lab.

------- Additional Comments From pbrown@redhat.com  03/22/99 14:23 -------
Michael, have you ever seen anything like this?  If not, we haven't
seen any reponses from this individual in months, and we should close
the bug.

------- Additional Comments From Juergen.Klotz@nbg6.siemens.de  03/24/99 05:01 -------
OOPS .....
I'm awefully sorry,
somehow your mail from 01/18/99 must have been dropped at my side!


This was the configuration when I postet the bug.
As you can see, I (unfortunately only) have three official addresses
and so I had to use a private one for the second interface on host B.

The machine the problem occured was host B.



+-----------------+       +----------------------------------+
+-----------------+
|        A        |       |                 B                |
|        C        |
| 193.174.  2. 12 |       | 193.174.  2.  8   10. 10. 10.  1 |       |
193.174.  2. 13 |
| 255.255.255.??? |       | 255.255.255.???  255.255.255.??? |       |
255.255.255.??? |
+-----------------+       +----------------------------------+
+-----------------+
         |                         |
|                       |
         + ------------------------+
+-----------------------+



At the moment, I do not remember the netmask as I'm currently only
running A and B and have no routing added for C.


The routing and interface configuration was done using linuxconf.
I've added an explicit host route to host C.
The output from linuxconf for the routing to C contained something
like "-host XXXXXX netmask 255.255.255.255" which was reject by
"route".


I'll try to figure out the old routing table and
interface configuration tomorrow if you want me to!




What I did to solve the problem at my side was to hack the code
of "route" to ignore the netmask for a explicit host routing.

Anyhow, I'm not shure if hacking code the way I did was a good
thing to do, but at least it solved my problem.

Anything was running quite well and so I forgot about the bug!
( ... hmmmmm, I think I remember ping complaining about having
 two interfaces for the route to C but it still worked!)

------- Additional Comments From Juergen.Klotz@nbg6.siemens.de  03/24/99 05:08 -------
+-----------------+
|   A        |
| 193.174.  2. 12 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2.  8 |----+
| 255.255.255.??? |
|                 |
|  10. 10. 10.  1 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2. 13 |----+
| 255.255.255.??? |
+-----------------+


------- Additional Comments From Juergen.Klotz@nbg6.siemens.de  03/24/99 07:48 -------
+-----------------+
|        A        |
| 193.174.  2. 12 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2.  8 |----+
| 255.255.255.??? |
|                 |
|  10. 10. 10.  1 |----+
| 255.255.255.??? |    |
+-----------------+    |
                       |
                       |
+-----------------+    |
|        C        |    |
| 193.174.  2. 13 |----+
| 255.255.255.??? |
+-----------------+