Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1522

Summary: IPX normally not running
Product: [Retired] Red Hat Linux Reporter: bombe
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-16 15:46:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description bombe 1999-03-16 07:10:41 UTC
The /etc/sysconfig/network-scripts/ifup-ipx script
doesn't configure correctly IPX interfaces. It reads the IPX
options from ifcfg-eth0, cuts the frame type and passes
frame type, network number, etc. to /usr/bin/ipx_interface
program. The problem is that the IPX frametypes are passed
as arguments to ipx_interface as 802_2 and 802_3 but
ipx_interface program expects that they're passed as 802.2
and 802.3. So, the solutions is to add next line in ifup-ipx
script just before the ipx_interface command is executed:

REAL_FRAMETYPE=`echo $frametype | sed 's/_/./g'`

and to change ipx_interface's option from FRAMETYPE to
REAL_FRAMETYPE

In this way the underbars are changed with periods for 802.2
and 802.3 frametypes. EtherII and SNAP frames are not
affected in this case. I haven't tested if they work - no
need at all.

Comment 1 Bill Nottingham 1999-03-16 15:46:59 UTC
this has been fixed in a later initscripts release.