Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1519731

Summary: pipewire-devel-0.1.6-1 misses spa/pod-parser.h
Product: [Fedora] Fedora Reporter: Robert Mader <robert.mader>
Component: pipewireAssignee: Wim Taymans <wtaymans>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: wtaymans
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-01 17:31:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert Mader 2017-12-01 10:44:01 UTC
Description of problem:
pipewire-devel does not provide the file /usr/include/spa/pod-parser.h, making it impossible to build packages against it.

Version-Release number of selected component (if applicable):
0.1.6-1

How reproducible:
Always.

Steps to Reproduce:
1. try to build e.g. mutter from srpm on a fully updated system

Actual results:
the build fails with the following error:
In file included from /usr/include/spa/node.h:34:0,
                 from /usr/include/pipewire/port.h:31,
                 from /usr/include/pipewire/core.h:45,
                 from /usr/include/pipewire/client.h:47,
                 from /usr/include/pipewire/pipewire.h:29,
                 from backends/meta-screen-cast.c:27:
/usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
 #include <spa/pod-parser.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.

Expected results:
It should compile

Additional info:
easy workaround: just get the file from github (https://raw.githubusercontent.com/PipeWire/pipewire/0.1.6/spa/include/spa/pod-parser.h)

Comment 1 Robert Mader 2017-12-01 10:45:07 UTC
*** Bug 1519203 has been marked as a duplicate of this bug. ***

Comment 2 Robert Mader 2017-12-01 17:31:09 UTC

*** This bug has been marked as a duplicate of bug 1514955 ***