Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1519336

Summary: dpdk-pmdinfo, from dpdk-tools, missing deps on python-pyelftools
Product: [Fedora] Fedora Reporter: Timothy Redaelli <tredaelli>
Component: dpdkAssignee: Neil Horman <nhorman>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aconole, linville, nhorman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-30 18:04:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Timothy Redaelli 2017-11-30 15:43:13 UTC
Description of problem:
dpdk-pmdinfo depends on python-pyelftools

Version-Release number of selected component (if applicable):
dpdk-17.11

How reproducible:
100%

Steps to Reproduce:
1. Install dpdk-tools (and dpdk-devel due to BZ#1519332)
2. Launch dpdk-pmdinfo

Actual results:
# dpdk-pmdinfo
Traceback (most recent call last):
  File "/usr/bin/dpdk-pmdinfo", line 14, in <module>
    from elftools.common.exceptions import ELFError
ImportError: No module named elftools.common.exceptions
# 

Expected results:
No traceback is shown

Additional info: