Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1518880

Summary: [RFE] Provide a Content View rpm and errata preview
Product: Red Hat Satellite 6 Reporter: Paul Armstrong <parmstro>
Component: WebUIAssignee: satellite6-bugs <satellite6-bugs>
WebUI sub component: Foreman QA Contact: Katello QA List <katello-qa-list>
Status: CLOSED DUPLICATE Docs Contact:
Severity: unspecified    
Priority: unspecified CC: bbuckingham, mhulan, sgraessl, tbrisker
Version: UnspecifiedKeywords: FutureFeature
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-07 20:54:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Armstrong 2017-11-29 17:08:35 UTC
Description of problem:
When generating a new set of filters for a content view it is difficult to determine the full impact of the filter before publishing. If the publishing process takes a long time due to CV size/scope and available resources, this can be frustrating. Such a feature would enhance the user experience and increase discoverability of function.


Version-Release number of selected component (if applicable):
Not specified

How reproducible:
New Feature Request

Steps to Reproduce:
1. Create a content view
2. Create a filter
3. Specify the filter
4. Return to the filter list
5. Select a "Preview Filters" button

Actual results:
Feature not implemented

Expected results:
Dialog or pane with package and errata summary and/or detailed list.
Click close to dismiss

Additional info:
Should be available as a hammer command as well

hammer content-view filter rule preview --organization "foo" --content-view "bar"

Comment 1 Brad Buckingham 2017-12-07 20:54:48 UTC
Thanks for opening this bugzilla!  The behavior described is definitely wanted and sounds similar to bug 1148490.  I am going to close this one as a duplicate; however, please feel free to re-open if there are any concerns.

*** This bug has been marked as a duplicate of bug 1148490 ***