Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1518545

Summary: [RFE] otopi should log on failure list of network connections
Product: [oVirt] otopi Reporter: Yedidyah Bar David <didi>
Component: Plugins.GeneralAssignee: Yedidyah Bar David <didi>
Status: CLOSED CURRENTRELEASE QA Contact: Lucie Leistnerova <lleistne>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: masterCC: bugs, lleistne, lsvaty, lveyde, trichard
Target Milestone: ovirt-4.1.9Keywords: FutureFeature
Target Release: 1.6.3Flags: sbonazzo: ovirt-4.1?
rule-engine: planning_ack?
sbonazzo: devel_ack+
lsvaty: testing_ack+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: otopi-1.6.3 Doc Type: Enhancement
Doc Text:
otopi now optionally logs the list of network connections on the machine after failures. Enable this by installing the optional otopi-debug-plugins package. This can help debug failures to start network services due to "Address already in use" errors.
Story Points: ---
Clone Of:
: 1518689 (view as bug list) Environment:
Last Closed: 2018-01-24 10:40:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1532525    

Description Yedidyah Bar David 2017-11-29 07:48:44 UTC
Description of problem:

We had several different cases lately of engine-setup or host-deploy failing to start services due to "Address already in use". It will be helpful if otopi logs e.g. the output of 'ss -anp' on failure.

This was already merged in the master branch, as a new debug plugin, always active if 'otopi-debug-plugins' is installed. Opening current bug for consideration for 4.1 (otopi 1.6 branch).

Comment 2 Lucie Leistnerova 2018-01-22 14:49:37 UTC
with installed rpm otopi-debug-plugins when engine-setup or host deploy fails, log contains:

2018-01-22 15:14:14 DEBUG otopi.plugins.otopi.debug.debug_failure.debug_failure debug_failure._notification:100 tcp connections:
id uid local foreign state pid exe
0: 29 0.0.0.0:40398 0.0.0.0:0 LISTEN 19376 /usr/sbin/rpc.statd
...

verified in otopi-1.6.3-1.el7ev.noarch, otopi-debug-plugins-1.6.3-1.el7ev.noarch with ovirt-engine-4.1.9-0.2.el7.noarch

Comment 3 Sandro Bonazzola 2018-01-24 10:40:45 UTC
This bugzilla is included in oVirt 4.1.9 release, published on Jan 24th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.1.9 release, published on Jan 24th 2018, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.