Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1518430

Summary: [Regression]Request screen is not shown on submitting order.
Product: Red Hat CloudForms Management Engine Reporter: Shveta <sshveta>
Component: UI - OPSAssignee: eclarizi
Status: CLOSED CURRENTRELEASE QA Contact: Dave Johnson <dajohnso>
Severity: high Docs Contact:
Priority: high    
Version: 5.9.0CC: cpelland, gmccullo, hkataria, jcutter, jhardy, mpovolny, obarenbo, pakotvan, tfitzger
Target Milestone: GAKeywords: Regression, TestOnly
Target Release: 5.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.10.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1519838 (view as bug list) Environment:
Last Closed: 2018-06-21 21:20:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: Bug
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core
Bug Depends On:    
Bug Blocks: 1519838    
Attachments:
Description Flags
request page not shown none

Description Shveta 2017-11-28 22:02:16 UTC
Created attachment 1360084 [details]
request page not shown

Description of problem: Like in 5.8 builds , when we order a service catalog, request page should be displayed .


Version-Release number of selected component (if applicable):
5.9.0.11.20171127204214_e316988 

How reproducible:


Steps to Reproduce:
1. Create a catalog and  catalog item.
2. Order service catalog. "dialog submitted successfully " is displayed and catalog item details are shown.
3. The navigation should take user to request page instead with Flash message 
"Order Request was Submitted"

Actual results:


Expected results:


Additional info:

Comment 4 Greg McCullough 2017-11-29 18:42:36 UTC
My understand is that this is an issue with the submit not returning a request object which is causing the UI to not switch to the request screen.

Erik, please review and work with Harpreet if needed.

Comment 6 Tina Fitzgerald 2017-11-29 19:24:27 UTC
Hi Shveta,

Can I access your appliance?

Thanks,
Tina

Comment 7 Shveta 2017-11-29 19:29:24 UTC
Appliance : https://10.8.197.197/

Comment 8 CFME Bot 2017-11-30 17:54:12 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/e8fb14fb7ad0d7a842c28bcd3122dbe0b0e36f60

commit e8fb14fb7ad0d7a842c28bcd3122dbe0b0e36f60
Author:     Erik Clarizio <eclarizio@gmail.com>
AuthorDate: Wed Nov 29 11:03:21 2017 -0800
Commit:     Erik Clarizio <eclarizio@gmail.com>
CommitDate: Wed Nov 29 13:56:17 2017 -0800

    Change redirect path and message after submission of service dialog
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1518430

 .../controllers/dialog_user/dialog_user_controller.js         |  4 ++--
 app/controllers/application_controller/buttons.rb             |  9 +++++----
 app/controllers/catalog_controller.rb                         | 11 ++++++++---
 app/views/shared/dialogs/_dialog_provision.html.haml          | 10 ++++++----
 app/views/shared/dialogs/_dialog_user.html.haml               |  1 +
 .../controllers/dialog_user/dialog_user_controller.spec.js    |  5 ++++-
 6 files changed, 26 insertions(+), 14 deletions(-)

Comment 9 eclarizi 2017-11-30 17:55:59 UTC
*** Bug 1519257 has been marked as a duplicate of this bug. ***

Comment 10 eclarizi 2017-11-30 22:03:34 UTC
*** Bug 1519491 has been marked as a duplicate of this bug. ***