Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1517689

Summary: Memory leak in locks xlator
Product: [Community] GlusterFS Reporter: Xavi Hernandez <jahernan>
Component: locksAssignee: Xavi Hernandez <jahernan>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.12CC: bugs
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-glusterfs-3.12.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1515161 Environment:
Last Closed: 2017-12-19 07:18:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1515161    
Bug Blocks:    

Description Xavi Hernandez 2017-11-27 08:55:46 UTC
+++ This bug was initially created as a clone of Bug #1515161 +++

Description of problem:

There are memory leaks of strings created with gf_strdup() in features/locks xlator.

Version-Release number of selected component (if applicable): master


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-11-27 08:57:46 UTC
REVIEW: https://review.gluster.org/18860 (features/locks: Fix memory leaks) posted (#1) for review on release-3.12 by Xavier Hernandez

Comment 2 Worker Ant 2017-11-30 06:42:55 UTC
COMMIT: https://review.gluster.org/18860 committed in release-3.12 by \"Xavier Hernandez\" <jahernan@redhat.com> with a commit message- features/locks: Fix memory leaks

Backport of:
> BUG: 1515161

Change-Id: Ic1d2e17a7d14389b6734d1b88bd28c0a2907bbd6
BUG: 1517689
Signed-off-by: Xavier Hernandez <jahernan@redhat.com>

Comment 3 Jiffin 2017-12-19 07:18:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.12.4, please open a new bug report.

glusterfs-glusterfs-3.12.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2017-December/054093.html
[2] https://www.gluster.org/pipermail/gluster-users/