Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1516935

Summary: NetworkManager does not connect to Wi-Fi, if you change the MAC address
Product: [Fedora] Fedora Reporter: Айфф <jamesbdonovan>
Component: NetworkManagerAssignee: lorenzo bianconi <lorenzo.bianconi>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: alexl, bgalvani, dcbw, fgiudici, gnome-sig, jamesbdonovan, john.j5live, lkundrak, mclasen, rhughes, rstrode, sandmann, thaller
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-28 15:15:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Айфф 2017-11-23 15:48:30 UTC
Can't connect to Wi-Fi via NetworkManager, if you change the MAC address (in settings “Clone MAC address”). If you connect without changing the MAC address, then everything works.

What could be the problem?

Comment 1 Thomas Haller 2017-11-23 16:28:54 UTC
The driver not supporting to change the MAC address.

Or a race condition in supplicant to not notice the MAC address change.


Provide a logfile if level=TRACE level ( https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/contrib/fedora/rpm/NetworkManager.conf ).

Comment 2 Айфф 2017-11-23 17:24:23 UTC
MT7601U wireless adapter.

https://paste.fedoraproject.org/paste/kktYUueZSn9TehC-lM8PNA

Comment 3 Thomas Haller 2017-11-23 22:11:49 UTC
Could be http://lists.infradead.org/pipermail/hostap/2017-October/038035.html

Beniamino?

Comment 4 Beniamino Galvani 2017-11-23 22:55:24 UTC
(In reply to Thomas Haller from comment #3)
> Could be http://lists.infradead.org/pipermail/hostap/2017-October/038035.html

It's possible.

(In reply to Айфф from comment #2)
> MT7601U wireless adapter.
> 
> https://paste.fedoraproject.org/paste/kktYUueZSn9TehC-lM8PNA

Hi, can you also attach wpa_supplicant debug logs? To capture them add '-dd' to OTHER_ARGS in /etc/sysconfig/wpa_supplicant, then run 'systemctl restart wpa_supplicant'; reproduce the issue and then attach the output of

  journalctl -u NetworkManager -u wpa_supplicant --since '2 minutes ago'

Thanks.