Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1516866

Summary: ima-evm-utils: Builds against compat-openssl10-devel which will be removed
Product: [Fedora] Fedora Reporter: Tomas Mraz <tmraz>
Component: ima-evm-utilsAssignee: Bruno Meneguele <brdeoliv>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: avagarwa, brdeoliv, labbott, vgoyal
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ima-evm-utils-1.0-3.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-06 16:50:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1383740    

Description Tomas Mraz 2017-11-23 13:05:21 UTC
The package currently depends on compat-openssl10-devel which will be removed. It needs to be ported to OpenSSL 1.1 API and built against regular openssl-devel package.

If you need help with porting the package feel free to contact me.

Comment 1 Bruno Meneguele 2017-11-23 13:14:21 UTC
Hi Tomas,

I'll take over this task considering I'm the one actively maintaining ima-evm-utils on Fedora.

About the port to OpenSSL 1.1, it's already in my TODO list for the next days. I've already took a look on that and it seems that there aren't to many things to be updated, but thank you for your help, be sure that I'll get in touch in case of something more complicated appears :).

ASAP I'll start to work on it!

Comment 2 Bruno Meneguele 2017-12-01 19:39:58 UTC
Hi, 

the patch is ready, but I've just sent an email to upstream's mailing list questioning about their interest in make the package openssl11-ready instead of a rpm specfile patch. In case they don't show up with something I'll push the patch I've made. Let's wait till next week at least.

Thanks.

Comment 3 Bruno Meneguele 2017-12-05 19:13:54 UTC
Upstream has plans to update the code to openssl1.1 api, and there is a chance that the patch that will be applied to the fedora's rpm can be the one to be applied in upstream as well.

  https://www.spinics.net/lists/linux-integrity/msg00897.html

However, they also have plans to add new features till next release thus I don't really know how long it'll take to be ready. Hence I'll push the new specfile and patch for openssl1.1 support.

Thanks.

Comment 4 Bruno Meneguele 2017-12-06 16:50:45 UTC
ima-evm-utils-1.0-3.fc28 pushed and built for rawhide:

https://src.fedoraproject.org/rpms/ima-evm-utils/c/f7d95ad7b17e0b0c614bf043d2af7efb4306ef9d
https://koji.fedoraproject.org/koji/buildinfo?buildID=1007760

I'll keep an eye in upstream's code base for official OpenSSL1.1 support.