Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1515819

Summary: GS doesn't see flatpak cli installed apps
Product: Red Hat Enterprise Linux 7 Reporter: Vladimir Benes <vbenes>
Component: gnome-softwareAssignee: Richard Hughes <rhughes>
Status: NEW --- QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.5CC: desktop-qa-list, rhughes
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1515816 Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1515816    
Bug Blocks:    

Description Vladimir Benes 2017-11-21 12:30:14 UTC
I installed LO via flatpak cli but then GS cannot see that app installed.


+++ This bug was initially created as a clone of Bug #1515816 +++

Description of problem:
I tried to install LO from flathub but no luck. I ended with:
lis 21 13:16:43 localhost.localdomain gnome-software-service.desktop[15902]: 12:16:43:0589 Gs  failed to call gs_plugin_app_install on flatpak: org.gnome.Platform branch 3.24 already installed
lis 21 13:16:43 localhost.localdomain gnome-software-service.desktop[15902]: 12:16:43:0589 Gs  not saving error for user/flatpak/org.libreoffice.LibreOffice-origin/desktop/org.libreoffice.LibreOffice.desktop/stable: org.gnome.Platform branch 3.24 already installed

but I was able to install Lo via cli:
vbenes@localhost:~$ flatpak install flathub org.libreoffice.LibreOffice
Updating: org.gnome.Platform/x86_64/3.24 from gnome
No updates.
Updating: org.gnome.Platform.Locale/x86_64/3.24 from gnome
No updates.
Installing: org.libreoffice.LibreOffice/x86_64/stable from flathub

12 delta parts, 92 loose fetched; 168267 KiB transferred in 11 seconds    


so it looks like GS cannot handle already installed dependencies.

Version-Release number of selected component (if applicable):
gnome-software-3.22.7-3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.go to flathub
2.download LO https://flathub.org/repo/appstream/org.libreoffice.LibreOffice.flatpakref
3.open it via GS

Actual results:
no luck

Expected results:
LO installed

Additional info: