Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1515509

Summary: Provider refresh triggers incorrect flash error message
Product: Red Hat CloudForms Management Engine Reporter: Mike Shriver <mshriver>
Component: UI - OPSAssignee: Dan Clarizio <dclarizi>
Status: CLOSED WORKSFORME QA Contact: Mike Shriver <mshriver>
Severity: high Docs Contact:
Priority: high    
Version: 5.9.0CC: cpelland, dclarizi, hkataria, jhardy, mpovolny, mshriver, obarenbo
Target Milestone: GAKeywords: Regression
Target Release: 5.9.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-12 18:52:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core Target Upstream Version:

Description Mike Shriver 2017-11-20 23:51:31 UTC
Description of problem:
Initiating a provider refresh via the cloud provider collection page (All providers) triggers a flash error message: "Cloud Provider no longer exists".

The provider is indeed still configured, and had been added recently. 

aws.log shows normal INFO logging on refresh cycles and when refresh is started from provider details page.

aws.log logs nothing when this error is triggered

Following was logged in evm.log when flash message displayed:
E, [2017-11-20T18:48:33.353409 #13228:a223f8] ERROR -- : MIQ(ems_cloud_controller-button): Cloud Provider no longer exists


Version-Release number of selected component (if applicable):
5.9.0.9

How reproducible:
100%

Steps to Reproduce:
1. Add cloud provider (ec2 govcloud if in US and have access)
2. Trigger refresh from the Configuration toolbar on the provider collection screen with a provider selected
3. Note error flash message
4. Note provider state

Actual results:
Provider is still configured, in VMDB.

Expected results:
Provider refresh starts with no messages.

Additional info:
Found with EC2's govcloud enabled account.

Comment 4 Mike Shriver 2017-12-08 14:39:01 UTC
Although the correct flash message is displayed for an EC2 provider on a standard region, I cannot fully test this in CFME 5.9.0.12 because of BZ 1523654.  The govcloud region is not available for selection, and this bug was observed with a govcloud region provider.

Comment 5 Mike Shriver 2017-12-11 14:38:44 UTC
I was able to re-enable the ec2 gov region where this behavior was observed, and in CFME 5.9.0.12 the flash message is correct on provider refresh for this ec2 region.

This BZ can be closed, fixed in latest build. No PR listed on BZ so I'm not sure exactly where the fix was introduced.