Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1514808

Summary: SELinux is preventing unsquashfs from 'map' accesses on the file /usr/bin/cp.
Product: [Fedora] Fedora Reporter: Predrag <predrag.zvijerac>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: dwalsh, lvrabec, mgrepl, plautrba, pmoore
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:2dae3c65018caa0b3c755e3ee06b36f20610d7d413e915a09e5c7cb6d3df5cfa;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-20 12:35:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Predrag 2017-11-18 17:26:39 UTC
Description of problem:
SELinux is preventing unsquashfs from 'map' accesses on the file /usr/bin/cp.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that unsquashfs should be allowed map access on the cp file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'unsquashfs' --raw | audit2allow -M my-unsquashfs
# semodule -X 300 -i my-unsquashfs.pp

Additional Information:
Source Context                system_u:system_r:snappy_t:s0
Target Context                system_u:object_r:bin_t:s0
Target Objects                /usr/bin/cp [ file ]
Source                        unsquashfs
Source Path                   unsquashfs
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.12-300.fc27.x86_64 #1 SMP Wed
                              Nov 8 16:38:01 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-11-16 21:51:25 CET
Last Seen                     2017-11-16 21:51:29 CET
Local ID                      413df7f0-917f-4e1a-91a0-0246c26aaf36

Raw Audit Messages
type=AVC msg=audit(1510865489.707:3193): avc:  denied  { map } for  pid=4763 comm="cp" path="/usr/bin/cp" dev="dm-1" ino=2228594 scontext=system_u:system_r:snappy_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file permissive=1


Hash: unsquashfs,snappy_t,bin_t,file,map


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-11-20 12:35:59 UTC

*** This bug has been marked as a duplicate of bug 1514800 ***