Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1514081

Summary: Disabling touchpad while typing does not work on T450s
Product: [Fedora] Fedora Reporter: Havoc Pennington <hp>
Component: gnome-desktopAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: alexl, bnocera, caillon+fedoraproject, fmuellner, gnome-sig, john.j5live, mbarnes, mclasen, rhughes, rstrode, sandmann, yselkowi
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-16 19:35:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Havoc Pennington 2017-11-16 15:41:48 UTC
(I know this is not filed on the right component but I don't know which component actually does this so hoping someone can move it)

I have /org/gnome/desktop/peripherals/touchpad/disable-while-typing set to true and while I'm typing I am getting tons of accidental clicks and touchpad events. While typing my insertion point jumps around or I lose focus depending on where the pointer is when the accidental click happens.

This is on a T450s.

My goal is to avoid accidental clicks while typing; fixing this or #1514077 or #1514079 would solve it for me, but for laptops without a trackpoint I guess this "disable while typing" feature is the only way.

I didn't notice this on Fedora <27 because I had the touchpad disabled.

Thank you

Comment 1 Havoc Pennington 2017-11-16 19:35:19 UTC
Update: the "disable touchpad" switch and related options weren't in my control center, but on suspend/unsuspend they re-appeared. It seems the desktop temporarily believed I had no touchpad hardware and so couldn't apply settings to it. So there's still some sort of bug where it can lose the touchpad, but disable-while-typing may well work when the desktop knows the touchpad exists.