Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513774

Summary: Review Request: ghc-warp-tls - HTTP over TLS support for Warp via the TLS package
Product: [Fedora] Fedora Reporter: Elliott Sales de Andrade <quantum.analyst>
Component: Package ReviewAssignee: Robert-André Mauchin <zebob.m>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: package-review, zebob.m
Target Milestone: ---Flags: zebob.m: fedora-review+
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ghc-warp-tls-3.2.4-1.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-21 12:49:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1513283    
Bug Blocks: 985082, 1491457    

Description Elliott Sales de Andrade 2017-11-15 23:03:37 UTC
Spec URL: http://qulogic.fedorapeople.org//ghc-warp-tls.spec
SRPM URL: http://qulogic.fedorapeople.org//ghc-warp-tls-3.2.4-1.git.64.ffc3148.fc26.src.rpm

Description:
SSLv1 and SSLv2 are obsoleted by IETF. We should use TLS 1.2 (or TLS 1.1 or TLS
1.0 if necessary). HTTP/2 can be negotiated by ALPN. API docs and the README
are available at <http://www.stackage.org/package/warp-tls>.

Comment 1 Elliott Sales de Andrade 2017-11-15 23:03:43 UTC
This package built on koji:  https://koji.fedoraproject.org/koji/taskinfo?taskID=23151449

Comment 2 Robert-André Mauchin 2017-11-16 15:23:47 UTC
Changelog version is no right:


* Sun Jul 23 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 3.2.3-1


It should be 3.2.4-1.

Fix this before import. Package accepted.

Comment 3 Gwyn Ciesla 2017-11-16 19:39:46 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/ghc-warp-tls

Comment 4 Fedora Update System 2018-02-26 09:24:59 UTC
ghc-http2-1.6.3-8.fc27 ghc-psqueues-0.2.4.0-8.fc27 ghc-tls-session-manager-0.0.0.1-1.fc27 ghc-wai-app-static-3.1.6.1-5.fc27 ghc-warp-3.2.13-1.fc27 ghc-warp-tls-3.2.4-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e9925d6cc

Comment 5 Fedora Update System 2018-02-26 17:32:36 UTC
ghc-http2-1.6.3-8.fc27, ghc-psqueues-0.2.4.0-8.fc27, ghc-tls-session-manager-0.0.0.1-1.fc27, ghc-wai-app-static-3.1.6.1-5.fc27, ghc-warp-3.2.13-1.fc27, ghc-warp-tls-3.2.4-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e9925d6cc