Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513582

Summary: Review Request: mpibash - Parallel scripting right from the Bourne-Again Shell
Product: [Fedora] Fedora Reporter: Christoph Junghans <junghans>
Component: Package ReviewAssignee: Björn 'besser82' Esser <besser82>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: besser82, package-review
Target Milestone: ---Flags: besser82: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-16 17:13:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Christoph Junghans 2017-11-15 16:07:08 UTC
Spec URL: https://junghans.fedorapeople.org/mpibash.spec
SRPM URL: https://junghans.fedorapeople.org/mpibash-1.2-1.fc26.src.rpm
Description: MPI-Bash makes it possible to parallelize Bash scripts which run a set of
Linux commands independently over a large number of input files. Because MPI-Bash includes various MPI functions for data transfer and synchronization, it is not limited to parallel workloads but can incorporate phased operations (i.e. all workers must finish operation X before any worker is allowed to begin operation Y).
Fedora Account System Username: junghans
Task ID: https://koji.fedoraproject.org/koji/taskinfo?taskID=23146235

Comment 1 Björn 'besser82' Esser 2017-12-03 16:20:13 UTC
I'd suggest using `%autosetup -p 1` over `%setup -q`, because it applies possibly needed future patches without further modification except for adding them to the spec file.

***

Would you mind taking those really easy ones in exchange?

https://bugzilla.redhat.com/show_bug.cgi?id=1520149
https://bugzilla.redhat.com/show_bug.cgi?id=1520150
https://bugzilla.redhat.com/show_bug.cgi?id=1520151
https://bugzilla.redhat.com/show_bug.cgi?id=1520152
https://bugzilla.redhat.com/show_bug.cgi?id=1520153

Comment 2 Björn 'besser82' Esser 2017-12-03 16:37:31 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines

  ---> That's happening because of the valid autogenerated file-requires
       dnf can not resolve locally.

- Header files in -devel subpackage, if present.
  Note: mpibash-debugsource :
  /usr/src/debug/mpibash-1.2-1.fc28.x86_64/src/mpibash.h
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DevelPackages

  ---> False positive.  Files is part of debugsources.

===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[-]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "GPL (v2 or later)", "GPL (v3 or later)",
     "Unknown or generated". 39 files have unknown license. Detailed output
     of licensecheck in
     /home/besser82/fedora/review/1513582-mpibash/licensecheck.txt

     ---> License is fine.  Other licenses come from auxilary files
          of Autotools

[x]: License file installed when any subpackage combination is installed.
[x]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/lib64/openmpi/lib/share,
     /usr/lib64/mpich/lib/share/mpibash, /usr/lib64/openmpi/lib/mpibash,
     /usr/lib64/mpich/lib/mpibash, /usr/lib64/openmpi/lib/share/mpibash,
     /usr/lib64/mpich/lib/share

     ---> Seems to be a bug in main openmpi / mpich packages…

[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/lib64/openmpi/lib,
     /usr/lib64/openmpi/lib/share/mpibash, /usr/lib64/openmpi/lib/share,
     /usr/lib64/mpich, /usr/lib64/mpich/lib/share,
     /usr/lib64/mpich/lib/share/mpibash, /usr/lib64/mpich/lib,
     /usr/lib64/mpich/lib/mpibash, /usr/lib64/openmpi,
     /usr/lib64/openmpi/lib/mpibash

     ---> Likewise.

[x]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(libgit2,
     libwayland-server, poppler-utils, virglrenderer, gnome-contacts,
     iputils, qt5-qtxmlpatterns, cups-client, gmime30, numactl-libs, gd,
     gc, iproute-tc, gvfs-fuse, tigervnc-server-minimal, libxshmfence,
     qemu-block-gluster, qemu-block-curl, libpurple, gpgme, osinfo-db-
     tools, libsndfile, expat, xorg-x11-drv-openchrome, libvisio,
     libmediaart, libmcpp, cyrus-sasl-md5, libibverbs, xorg-x11-server-
     utils, libproxy-mozjs, giflib, libreoffice-graphicfilter, gdb-
     headless, gnome-maps, python2-cffi, gstreamer1-plugins-ugly-free,
     dleyna-core, qemu-block-nfs, libgovirt, bzip2-libs, libqmi-utils,
     xorg-x11-drv-nouveau, unzip, psacct, dbus-libs, libdb-utils, alsa-
     plugins-pulseaudio, tracker-miners, xorg-x11-font-utils, gtk2,
     PackageKit-command-not-found, libXScrnSaver, libreoffice-gtk3,
     libcom_err, totem, libseccomp, gnutls, gnome-bluetooth-libs, atkmm,
     perl-Digest-SHA, usbredir, abrt-addon-coredump-helper, libglvnd-glx,
     p11-kit, efivar-libs, iptables-libs, libabw, device-mapper-persistent-
     data, gtkspell, cryptsetup-libs, libesmtp, ykpers, gnome-system-
     monitor, libmodman, libvirt-daemon-driver-nwfilter, ttmkfdir,
     libselinux-utils, libkadm5, perl-Scalar-List-Utils, argyllcms, parted,
     libuser, gspell, libdvdread, perl-version, zstd, xcb-util-image, m17n-
     lib, mozjs17, bluez-libs, mesa-libwayland-egl, libblockdev-mdraid,
     rng-tools, glusterfs, exiv2-libs, lua-posix, python3-cups, libwebp,
     libxslt, gdbm, libreport-cli, xorg-x11-server-Xwayland, system-config-
     printer-udev, python3-dmidecode, python3-hawkey, libunistring, abrt-
     gui-libs, keyutils-libs, perl-Encode, elfutils, libproxy, libevdev,
     libgpg-error, sssd-common-pac, libgdata, libosinfo, sane-backends-
     drivers-cameras, dleyna-server, gnome-screenshot, libreoffice-math,
     libtimezonemap, corosync, bind99-libs, perl-Data-Dumper, upower, isns-
     utils-libs, libreoffice-calc, at-spi2-core, libqmi, gutenprint-cups,
     hypervvssd, gawk, dmraid-events, pcsc-lite-libs, abrt, libasyncns,
     ibus-m17n, adwaita-gtk2-theme, anaconda-core, python2-pygpgme, device-
     mapper-multipath, c-ares, xmlsec1-openssl, lua-lpeg, gnome-keyring-
     pam, libvirt-daemon-driver-network, python2-cairo, ethtool, gfbgraph,
     python3-cryptography, baobab, rdma-core, NetworkManager-pptp-gnome,
     python-xpyb, jansson, vte291, libcdr, b43-fwcutter, libgweather, sssd-
     krb5, e2fsprogs-libs, pulseaudio-libs, perl-Params-Util, libsmbclient,
     librsvg2, gtk3, lcms2, alsa-utils, apr, libatasmart, nautilus-dropbox,
     mlocate, farstream02, tmux, qemu-guest-agent, ntfs-3g, file-libs,
     libgrss, grub2-tools, libxcb, libtevent, trousers-lib, libyubikey,
     gnome-initial-setup, avahi-glib, python3-pycurl, mokutil, openconnect,
     libblockdev-swap, tar, xcb-util-keysyms, libreport-plugin-systemd-
     journal, libnetfilter_conntrack, webrtc-audio-processing, bcache-
     tools, python3-gobject, startup-notification, m4, lksctp-tools,
     frei0r-plugins, python2-hawkey, fprintd-pam, libgepub, libvdpau,
     libusbx, sudo, libgphoto2, NetworkManager-openvpn-gnome, compat-
     openssl10, evince-nautilus, qrencode-libs, pidgin, libICE, pinfo,
     libgexiv2, drpm, xcb-util, libtar, python2-librepo, createrepo_c-libs,
     evolution-data-server, grilo, bubblewrap, libgpod, libtasn1, speexdsp,
     libblockdev-dm, python3-coverage, openCOLLADA, xcb-util-renderutil,
     libjpeg-turbo, libe-book, anaconda-widgets, libreoffice-x11,
     python3-dbus, http-parser, sssd-ad, iscsi-initiator-utils-iscsiuio,
     xcb-util-wm, pulseaudio-utils, libpinyin, speech-dispatcher-espeak,
     nmap-ncat, openssl, logrotate, libmbim-utils, dhcp-client, fprintd,
     dbxtool, pinentry-gtk, libarchive, libexif, systemd-bootchart, scl-
     utils, dwz, alsa-lib, libdnet, libblockdev-lvm, xorg-x11-drv-qxl,
     cyrus-sasl-gssapi, gcr, ntfsprogs, python2-gobject, abrt-libs, abrt-
     addon-pstoreoops, gtkmm24, ebtables, libvirt-daemon-driver-storage-
     disk, brasero-libs, avahi-libs, libeot, mesa-dri-drivers, libgdither,
     dbusmenu-qt, NetworkManager, trousers, sgpio, ncurses-libs, libidn2,
     device-mapper-libs, pigz, libfdt, checkpolicy, libquvi, libpsl,
     libreport-plugin-logger, gnome-color-manager, fcoe-utils, xorg-x11
     -xkb-utils, evince-djvu, libgnomekbd, NetworkManager-ssh,
     NetworkManager-openvpn, ibus-rawcode, libxkbfile, policycoreutils-
     python-utils, python3-rpm, pciutils, nautilus-sendto, libwvstreams,
     fwupdate-libs, jimtcl, libao, gnome-boxes, openssh-clients, hostname,
     python3-libs, mesa-libxatracker, cryptsetup, perl-libs, libwpd,
     libX11, celt051, kbd, libvirt-daemon-driver-qemu, kexec-tools, rpm-
     build, boost-date-time, kyotocabinet-libs, python3-pwquality, qemu-
     block-ssh, gvfs-mtp, libwps, libreoffice-core, gssdp, gnome-bluetooth,
     sane-backends, mythes, libpath_utils, satyr, libacl, caribou-
     gtk3-module, libwayland-cursor, gnome-software, openvpn, libnl3,
     libcap-ng, ibus, libSM, policycoreutils, pixman, gnome-font-viewer,
     abrt-plugin-bodhi, libmusicbrainz5, pptp, libidn, npth, libXxf86misc,
     libwacom, libbluray, foomatic, grubby, libatomic_ops, lzo, brltty,
     NetworkManager-wifi, pango, vpnc, colord-gtk, python-krbV,
     pcre2-utf16, libss, libbabeltrace, mod_dnssd, corosynclib, nspr,
     esmtp, dbus, qemu-block-rbd, polkit-libs, python3-systemd, psmisc,
     net-snmp-libs, perl-threads, python2-cryptography, perl-Params-
     Validate, xorg-x11-drv-libinput, mcelog, pangomm, ibus-libs,
     libsss_certmap, libvirt-daemon-driver-storage-sheepdog, libglvnd-gles,
     setroubleshoot, sg3_utils-libs, python2-libcomps, rpm-plugin-systemd-
     inhibit, cairo, cifs-utils, audit-libs, libwnck3, nss-sysinit,
     libsane-hpaio, LibRaw, libgcc, libmng, sssd-ldap, libvirt-daemon-
     driver-storage-iscsi, libbasicobjects, gstreamer1, gettext-libs, p11
     -kit-trust, gom, nss-mdns, samba-common-libs, efibootmgr, gvfs-afp,
     ncurses-compat-libs, gnome-disk-utility, python3-cffi, poppler,
     libstemmer, gvfs-afc, sshpass, hexchat, djvulibre-libs, switcheroo-
     control, libcanberra-gtk3, cairo-gobject, nm-connection-editor, ibus-
     libzhuyin, gtk-update-icon-cache, xdg-desktop-portal-gtk, net-tools,
     ModemManager, abrt-gui, sssd-kcm, xorg-x11-drv-intel, libcrypt-nss,
     plymouth-plugin-two-step, libvirt-daemon-driver-storage-scsi, spice-
     glib, sbc, qemu-img, git, qt-x11, qt5-qtbase-gui, libhangul,
     gutenprint, rtkit, usermode, orc, bash, glibc-common, poppler-glib,
     qpdf-libs, linux-atm-libs, libedit, polkit, python3-librepo, libuuid,
     environment-modules, atk, wavpack, python3-cairo, accountsservice,
     libfreehand, ibus-gtk3, ibus-gtk2, augeas-libs, protobuf-c, pkgconf,
     hfsplus-tools, cheese, udisks2, xorg-x11-utils, clucene-contribs-lib,
     lvm2, mpg123-libs, paps-libs, tcp_wrappers, libblockdev-btrfs,
     harfbuzz, dconf-editor, xz, libXcomposite, vconfig, mtools, pygtk2,
     gupnp-av, python3-libxml2, libnfs, cups, librepo, dmraid, libvirt-
     daemon, vim-minimal, harfbuzz-icu, vino, gstreamer1-plugins-base,
     stoken-libs, libpkgconf, libplist, python3-iscsi-initiator-utils,
     liblockfile, python3-wrapt, gdm, gvfs-client, NetworkManager-libnm,
     xdg-user-dirs, libvirt-daemon-driver-interface, libiscsi, passwdqc,
     vim-enhanced, liblangtag, glusterfs-libs, speech-dispatcher, groff-
     base, pygobject2, libdatrie, spice-server, gdk-pixbuf2, glade-libs,
     setuptool, lrzsz, gupnp, authconfig, libusb, dhcp-libs, redland,
     python2-cccolutils, libtalloc, mesa-libGL, abrt-addon-ccpp, libldb,
     grep, hypervkvpd, libsmbios, git-core, tree, ghostscript-x11, python2
     -gobject-base, libsigsegv, zfs-fuse, mdadm, pipewire, libepoxy, gnupg,
     libvirt-daemon-driver-nodedev, libXres, NetworkManager-glib,
     libcanberra, ibus-hangul, rpm-plugin-selinux, cronie-anacron, gvfs-
     archive, xfsprogs, control-center, python2-rpm, libblockdev-kbd,
     libcroco, grub2-tools-extra, gedit, libinput, gnome-abrt, libgcrypt,
     PackageKit-gstreamer-plugin, libappstream-glib, libblockdev,
     librdmacm, libgudev, dconf, xz-libs, dbus-glib, cyrus-sasl-plain,
     perl-Filter, timedatex, libsrtp, perl-Package-Stash-XS, telepathy-
     glib, samba-client-libs, libdvdnav, plymouth-plugin-label, libspectre,
     colord-libs, python3-pygit2, which, libcap, libvirt-daemon-driver-
     storage-zfs, samba-client, perl-Variable-Magic, glib-networking, lua-
     expat, wireless-tools, hplip-libs, libdb, exiv2, passwd, cups-pk-
     helper, efivar, gpgmepp, libgcab1, libvirt-daemon-driver-storage-
     gluster, libzhuyin, libdv, gutenprint-libs, libnice, libreoffice-
     writer, desktop-file-utils, libXdamage, hypervfcopyd, libsmartcols,
     gvfs-gphoto2, libblockdev-part, libexttextcat, brlapi, libusal,
     mod_http2, libcanberra-gtk2, redhat-lsb-core, libreport, libthai,
     createrepo_c, libcryptui, tracker, gnome-session, dleyna-connector-
     dbus, gtkmm30, libv4l, libini_config, libverto-libev, luajit, numad,
     speex, liboauth, nss-tools, colord, adcli, libpipeline, pkcs11-helper,
     accountsservice-libs, libevent, device-mapper, xmlsec1, iproute,
     xmlrpc-c-client, python2-gpg, findutils, popt, vim-common, gsound,
     fakeroot-libs, bind-libs, libsss_idmap, gobject-introspection,
     libpwquality, lvm2-libs, libraw1394, libwsman1, python3-kerberos,
     fontconfig, krb5-workstation, libwpg, folks, os-prober, gnome-clocks,
     jbigkit-libs, python2-libs, iptables, mcpp, freetype, libipa_hbac,
     kpartx, libfprint, systemd-libs, cpio, lz4, rest, lz4-libs, libgltf,
     usb_modeswitch, util-linux, libdaemon, guile, evolution, dotconf, qt,
     abrt-retrace-client, libXfont, perl-Sort-Key, evince, PackageKit-glib,
     patch, krb5-libs, sqlite-libs, sssd-common, gnome-online-accounts,
     audit-libs-python3, libconfig, lttng-ust, teamd, libvorbis, enchant,
     acl, NetworkManager-openconnect-gnome, rpcbind, enca, libXxf86dga,
     json-c, xdg-user-dirs-gtk, libodfgen, libwayland-client, liblouis,
     pinentry-gnome3, libpciaccess, NetworkManager-adsl, sed, libipt,
     clucene-core, libsss_autofs, perl-threads-shared, libchamplain,
     flatpak, libaio, kmod, NetworkManager-ssh-gnome, NetworkManager-pptp,
     gnome-calculator, gnome-terminal, libetonyek, gvfs-goa, samba-libs,
     lua, purple-hangouts, libXtst, gnome-documents-libs, gnome-user-share,
     libpng, openssl-libs, ghostscript-core, sane-backends-libs,
     python3-pillow, raptor2, sssd-client, libgxps, dbus-x11, gnome-online-
     miners, GeoIP, cyrus-sasl, systemd, gstreamer1-plugins-good,
     libpagemaker, llvm-libs, hardlink, libsigc++20, libreport-plugin-
     bugzilla, python2-talloc, pakchois, libXrandr, newt, libreport-plugin-
     reportuploader, libpeas-loader-python3, libglvnd-egl, libsolv,
     pulseaudio-module-bluetooth, libxkbcommon, liba52, hplip,
     python3-abrt, gnome-todo, cairomm, device-mapper-multipath-libs,
     libzstd, yajl, lockdev, gnome-calendar, nss-softokn, gtk-murrine-
     engine, crda, libXft, lsof, libical, at-spi2-atk, libattr,
     NetworkManager-vpnc, sssd-ipa, geocode-glib, libreoffice-impress, ima-
     evm-utils, hyphen, adwaita-qt4, adwaita-qt5, initscripts,
     gnupg2-smime, thermald-monitor, webkitgtk4, lpsolve, libXfont2, rpm,
     gnome-terminal-nautilus, mozjs52, xorg-x11-server-Xorg, libssh2,
     usbmuxd, python3-libcomps, open-vm-tools-desktop, gnome-characters,
     samba-dc-libs, libpskc, gnupg2, perl-IO, PackageKit, libverto,
     glibmm24, gnome-logs, iio-sensor-proxy, iptstate, bridge-utils,
     libreport-plugin-ureport, radvd, cracklib, procps-ng, realmd,
     libmspub, plymouth-core-libs, ncurses, xorg-x11-drv-ati, symlinks,
     telnet, graphite2, libblockdev-loop, simple-scan, libXpm, libreport-
     plugin-kerneloops, libunwind, glusterfs-cli, perl-PathTools, gnome-
     keyring, libtdb, ipset-libs, bluez-obexd, pulseaudio-libs-glib2, sssd-
     krb5-common, zlib, libvirt-daemon-driver-storage-core, libnice-
     gstreamer1, libpeas, lxpolkit, pam_krb5, plymouth-graphics-libs, grub2
     -tools-efi, avahi, libselinux, volume_key-libs, mozjs38, cdparanoia-
     libs, python3-pyparted, gnome-menus, glusterfs-client-xlators,
     python2-lxml, libreoffice-pyuno, python2, libassuan, python3-gpg,
     libxml2, gstreamer1-plugins-bad-free, sushi, cups-filters, iw,
     clutter-gtk, libreoffice-ure, libzapojit, clutter, userspace-rcu,
     perl-interpreter, zenity, powerline, libblockdev-utils, rhythmbox,
     chkconfig, lua-socket, bluez-cups, mpage, glusterfs-fuse, libnm-gtk,
     ibus-libpinyin, libgnome-keyring, libcurl, mousetweaks, make,
     python3-markupsafe, libsemanage-python3, iscsi-initiator-utils, man-
     db, coreutils, bind-utils, libsecret, xorg-x11-drv-wacom, dosfstools,
     librados2, libvirt-daemon-driver-storage-mpath, gvfs, mesa-libgbm,
     pam, util-linux-user, liborcus, NetworkManager-bluetooth, libsoup,
     glusterfs-api, pinentry, yelp-libs, sane-backends-drivers-scanners,
     fuse, perl-Net-SSLeay, libsysfs, gssproxy, libmpcdec, xorg-x11-drv-
     vesa, geoclue2, audit, NetworkManager-wwan, libreoffice-gtk2, cups-
     filters-libs, file-roller-nautilus, cups-libs, nautilus-extensions,
     java-1.8.0-openjdk-headless, ipcalc, abrt-dbus, gnome-desktop3, gdk-
     pixbuf2-modules, binutils, libsepol, totem-pl-parser, gzip, qemu-
     common, xen-libs, qgnomeplatform, gsm, boost-filesystem, keyutils,
     setroubleshoot-server, nss-pem, libvirt-daemon-driver-storage-logical,
     ibus-wayland, python2-kerberos, less, isomd5sum, neon, libfdisk,
     libvpx, openssh, tcl, rpm-build-libs, libnghttp2, libsamplerate,
     purple-facebook, libdmx, libglvnd, NetworkManager-vpnc-gnome, boost-
     iostreams, sheepdog, ostree-libs, totem-nautilus, pcre2, opencc,
     boost-system, libpcap, exempi, qt5-qtdeclarative, libxkbcommon-x11,
     qemu-block-iscsi, snappy, python3, gavl, gmp, libusbmuxd, perl-
     Unicode-Normalize, sssd-nfs-idmap, libXdmcp, libgadu, gperftools-libs,
     ipset, clutter-gst3, libimobiledevice, lzop, perl-Socket, libselinux-
     python3, libsss_nss_idmap, apr-util, elfutils-libelf, libdrm,
     genisoimage, polkit-pkla-compat, libvisual, python3-libreport, unique,
     espeak, epiphany-runtime, shotwell, cyrus-sasl-lib, librevenge,
     libtirpc, qt5-qtbase, keybinder3, deltarpm, libbytesize, xmlrpc-c,
     fuse-libs, python3-gobject-base, perl-TermReadKey, xdg-desktop-portal,
     libudisks2, thermald, dnsmasq, geoclue2-libs, cogl, rygel,
     xorg-x11-xauth, libXfixes, shared-mime-info, setools-python3, gupnp-
     dlna, gvfs-smb, gtkspell3, libblkid, rasqal, gjs, libcue, libcdio,
     libXrender, json-glib, telepathy-logger, libwbclient, libX11-xcb,
     libfontenc, libblockdev-mpath, libicu, libgsf, rsync, GConf2, caribou-
     gtk2-module, grilo-plugins, NetworkManager-openconnect, libgtop2,
     glibc, webkitgtk4-jsc, gnome-settings-daemon, btrfs-progs, shadow-
     utils, lua-libs, libcgroup, wvdial, libXau, flatpak-libs, fipscheck,
     netcf-libs, mactel-boot, bc, soundtouch, xorg-x11-drv-evdev, sni-qt,
     gtk-vnc2, python3-brlapi, pulseaudio-module-x11, dmidecode, mesa-
     libglapi, syslinux, libpeas-gtk, libXinerama, libnl3-cli, wget, glx-
     utils, kmod-libs, gnome-autoar, libteam, libimagequant, libmbim,
     syslinux-extlinux, libcmis, zip, elfutils-libs, perl-MIME-Base64,
     spice-gtk3, libreport-web, nautilus, gvnc, libgomp, libmount, libvirt-
     daemon-driver-secret, cyrus-sasl-scram, spice-vdagent, xorg-x11-drv-
     fbdev, libgusb, glib2, libcollection, libqb, libavc1394, libreport-
     gtk, lldpad, mutter, libphodav, qemu-system-x86-core, libtiff,
     wpa_supplicant, libev, libstdc++, libtool-ltdl, libmnl, ppp, libgee,
     libzmf, rdist, gdisk, libnotify, libXcursor, nfs-utils, dos2unix,
     libXxf86vm, httpd-tools, pcre, mesa-libEGL, libchamplain-gtk, cronie,
     SDL2, tcp_wrappers-libs, httpd, openldap, systemd-pam, opus, spax,
     gupnp-igd, paps, ed, libvirt-libs, tcpdump, bind-libs-lite, perl-
     Storable, perl-Digest-MD5, pciutils-libs, libxklavier, traceroute,
     PackageKit-gtk3-module, libiptcdata, libmpc, openssh-server, libXi,
     libblockdev-crypto, file-roller, openjpeg2, libshout, flac-libs,
     taglib, libXt, libreoffice-pdfimport, libXv, rpm-libs, libXext, rp-
     pppoe, libtheora, info, ModemManager-glib, libnfnetlink, dracut,
     ostree, attr, libiec61883, mtr, perl-Unicode-UTF8, device-mapper-
     event-libs, gtksourceview3, libvirt-daemon-driver-storage-rbd,
     libnfsidmap, libreofficekit, nss-util, plymouth, bluez, device-mapper-
     event, hunspell, fwupd, libsemanage, highlight, marisa, gstreamer1
     -plugins-bad-free-gtk, libieee1284, gnome-shell, libndp, libreoffice-
     base, mtdev, systemd-container, libcomps, java-1.8.0-openjdk, mailx,
     libmspack, systemd-udev, evince-libs, pulseaudio, meanwhile, jwhois,
     qemu-block-dmg, file, libsss_sudo, libXvMC, libmwaw, curl, cheese-
     libs, abrt-addon-kerneloops, nettle, bzip2, libssh, libblockdev-fs,
     libdmapsharing, quota, libXmu, libnma, gettext, fakeroot, soxr, nss-
     softokn-freebl, fipscheck-lib, libmtp, open-vm-tools, evolution-ews,
     jasper-libs, librbd1, lame-libs, libdhash, python2-pycurl, xorg-x11
     -drv-vmware, libutempter, libdnf, xorg-x11-xinit, libogg, libmetalink,
     pyliblzma, libffi, NetworkManager-team, readline, libcacard, slang,
     libstaroffice, abrt-tui, eog, libref_array, yelp, webkitgtk4-plugin-
     process-gtk2, nss, diffutils, usbutils, e2fsprogs, libcdio-paranoia,
     chrony, abrt-addon-xorg, grub2-tools-minimal, abrt-java-connector,
     ibus-qt, time, at, passwdqc-lib, libksba, caribou, sssd-proxy, mpfr),
     /usr/lib/.build-id/c4(httpd, parted, psacct, libxcb, coreutils,
     ncurses, pulseaudio, kbd, libunwind, polkit, libcdio, perl-
     interpreter, python3-libxml2, folks, xen-libs, util-linux, gnome-
     software, libreoffice-core), /usr/lib/.build-id/0b(argyllcms, parted,
     nss-tools, iputils, gvfs-mtp, libreoffice-core, httpd, hypervvssd,
     java-1.8.0-openjdk-headless, glibc, coreutils, gcr, man-db, radvd,
     iptables, libgphoto2, libdb-utils, util-linux, mcpp, psmisc, device-
     mapper-multipath-libs, libmodman, samba-client-libs)

     ---> False positive.

[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
     Note: Incorrect Requires : /usr/lib64/openmpi/bin/mpibash,
     /usr/lib64/openmpi/bin/mpibash, /usr/lib64/mpich/bin/mpibash,
     /usr/lib64/mpich/bin/mpibash
     See: http://fedoraproject.org/wiki/Packaging/Guidelines#FileDeps

     ---> This is expected since rhose interpreters live inside a private
          dir as required by guidelines.

[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in mpibash-
     openmpi , mpibash-mpich , mpibash-openmpi-examples , mpibash-mpich-
     examples , mpibash-debuginfo , mpibash-debugsource

     ---> Requires are fine the way, they are.

[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.


===== EXTRA items =====

Generic:
[-]: Rpmlint is run on all installed packages.
     Note: Mock build failed
     See: http://fedoraproject.org/wiki/Packaging/Guidelines#rpmlint
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Installation errors
-------------------
INFO: mock.py version 1.4.7 starting (python version = 3.6.3)...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Start: chroot init
INFO: calling preinit hooks
INFO: enabled root cache
INFO: enabled dnf cache
Start: cleaning dnf metadata
Finish: cleaning dnf metadata
INFO: enabled HW Info plugin
Mock Version: 1.4.7
INFO: Mock Version: 1.4.7
Finish: chroot init
INFO: installing package(s): /home/besser82/fedora/review/1513582-mpibash/results/mpibash-debugsource-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-debuginfo-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-examples-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-examples-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-debuginfo-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-debuginfo-1.2-1.fc28.x86_64.rpm
ERROR: Command failed: 
 # /usr/bin/dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 28 --disableplugin=local --setopt=deltarpm=False install /home/besser82/fedora/review/1513582-mpibash/results/mpibash-debugsource-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-debuginfo-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-examples-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-examples-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-mpich-debuginfo-1.2-1.fc28.x86_64.rpm /home/besser82/fedora/review/1513582-mpibash/results/mpibash-openmpi-debuginfo-1.2-1.fc28.x86_64.rpm


Rpmlint
-------
Checking: mpibash-openmpi-1.2-1.fc28.x86_64.rpm
          mpibash-mpich-1.2-1.fc28.x86_64.rpm
          mpibash-openmpi-examples-1.2-1.fc28.x86_64.rpm
          mpibash-mpich-examples-1.2-1.fc28.x86_64.rpm
          mpibash-debuginfo-1.2-1.fc28.x86_64.rpm
          mpibash-debugsource-1.2-1.fc28.x86_64.rpm
          mpibash-1.2-1.fc28.src.rpm
mpibash-openmpi.x86_64: W: spelling-error %description -l en_US parallelize -> parallelism, paralleled, parallel
mpibash-openmpi.x86_64: E: invalid-locale-man-dir /usr/share/man/openmpi-x86_64/man1/mbxz_openmpi.1.gz
mpibash-openmpi.x86_64: W: file-not-in-%lang /usr/share/man/openmpi-x86_64/man1/mbxz_openmpi.1.gz
mpibash-mpich.x86_64: W: spelling-error %description -l en_US parallelize -> parallelism, paralleled, parallel
mpibash-mpich.x86_64: E: invalid-locale-man-dir /usr/share/man/mpich-x86_64/man1/mbxz_mpich.1.gz
mpibash-mpich.x86_64: W: file-not-in-%lang /usr/share/man/mpich-x86_64/man1/mbxz_mpich.1.gz
mpibash-openmpi-examples.x86_64: W: spelling-error %description -l en_US parallelize -> parallelism, paralleled, parallel
mpibash-openmpi-examples.x86_64: W: only-non-binary-in-usr-lib
mpibash-openmpi-examples.x86_64: W: no-documentation
mpibash-mpich-examples.x86_64: W: spelling-error %description -l en_US parallelize -> parallelism, paralleled, parallel
mpibash-mpich-examples.x86_64: W: only-non-binary-in-usr-lib
mpibash-mpich-examples.x86_64: W: no-documentation
mpibash-debugsource.x86_64: W: no-documentation
mpibash.src: W: spelling-error %description -l en_US parallelize -> parallelism, paralleled, parallel
mpibash.src:72: W: configure-without-libdir-spec
7 packages and 0 specfiles checked; 2 errors, 13 warnings.


Requires
--------
mpibash-debuginfo (rpmlib, GLIBC filtered):

mpibash-openmpi (rpmlib, GLIBC filtered):
    /bin/bash
    /usr/lib64/openmpi/bin/mpibash
    libc.so.6()(64bit)
    libdl.so.2()(64bit)
    libmpi.so.20()(64bit)(openmpi-x86_64)
    libpthread.so.0()(64bit)
    rtld(GNU_HASH)

mpibash-openmpi-examples (rpmlib, GLIBC filtered):
    /usr/lib64/openmpi/bin/mpibash
    mpibash-openmpi

mpibash-debugsource (rpmlib, GLIBC filtered):

mpibash-mpich-examples (rpmlib, GLIBC filtered):
    /usr/lib64/mpich/bin/mpibash
    mpibash-mpich

mpibash-mpich (rpmlib, GLIBC filtered):
    /bin/bash
    /usr/lib64/mpich/bin/mpibash
    libc.so.6()(64bit)
    libdl.so.2()(64bit)
    libmpi.so.12()(64bit)(mpich-x86_64)
    rtld(GNU_HASH)


Provides
--------
mpibash-debuginfo:
    mpibash-debuginfo
    mpibash-debuginfo(x86-64)

mpibash-openmpi:
    mpibash-openmpi
    mpibash-openmpi(x86-64)

mpibash-openmpi-examples:
    mpibash-openmpi-examples
    mpibash-openmpi-examples(x86-64)

mpibash-debugsource:
    mpibash-debugsource
    mpibash-debugsource(x86-64)

mpibash-mpich-examples:
    mpibash-mpich-examples
    mpibash-mpich-examples(x86-64)

mpibash-mpich:
    mpibash-mpich
    mpibash-mpich(x86-64)


Unversioned so-files
--------------------
mpibash-openmpi: /usr/lib64/openmpi/lib/mpibash/mpibash.so
mpibash-mpich: /usr/lib64/mpich/lib/mpibash/mpibash.so

Source checksums
----------------
https://github.com/lanl/MPI-Bash/releases/download/v1.2/mpibash-1.2.tar.gz :
  CHECKSUM(SHA256) this package     : 5c2faaa74464111205dbae4799bd89c2425810ec3708d004237b42d620c8be57
  CHECKSUM(SHA256) upstream package : 5c2faaa74464111205dbae4799bd89c2425810ec3708d004237b42d620c8be57


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -m fedora-rawhide-x86_64 -b 1513582
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

===== Solution =====

Package APPROVED!!!

Comment 3 Christoph Junghans 2017-12-03 21:31:17 UTC
(In reply to Björn "besser82" Esser from comment #1)
> I'd suggest using `%autosetup -p 1` over `%setup -q`, because it applies
> possibly needed future patches without further modification except for
> adding them to the spec file.
> 
> ***
> 
> Would you mind taking those really easy ones in exchange?
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1520149
> https://bugzilla.redhat.com/show_bug.cgi?id=1520150
> https://bugzilla.redhat.com/show_bug.cgi?id=1520151
> https://bugzilla.redhat.com/show_bug.cgi?id=1520152
> https://bugzilla.redhat.com/show_bug.cgi?id=1520153

Sorry, I was too late, so I owe you one review, ping me the next time around!

Comment 4 Gwyn Ciesla 2017-12-04 14:05:33 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/mpibash

Comment 5 Fedora Update System 2018-01-04 16:27:00 UTC
mpibash-1.3-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c510d0ed90

Comment 6 Fedora Update System 2018-01-05 11:58:53 UTC
mpibash-1.3-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c510d0ed90

Comment 7 Fedora Update System 2018-01-16 17:13:29 UTC
mpibash-1.3-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.