Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513543

Summary: [RFE] Add block job to create format on a storage device
Product: Red Hat Enterprise Linux 7 Reporter: Peter Krempa <pkrempa>
Component: qemu-kvm-rhevAssignee: Kevin Wolf <kwolf>
Status: CLOSED ERRATA QA Contact: Gu Nini <ngu>
Severity: high Docs Contact:
Priority: high    
Version: 7.5CC: areis, brault, chayang, coli, jsuchane, juzhang, knoel, kwolf, michen, mreitz, mtessun, ngu, pgrist, pingl, pkrempa, qzhang, rcyriac, virt-maint, xianwang
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qemu-kvm-rhev-2.12.0-6.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-01 11:01:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 760547, 1558125    

Description Peter Krempa 2017-11-15 15:27:11 UTC
Description of problem:
To allow using blockdev-add for external snapshots (blockdev-snapshot) or blockdev mirror it's necessary to create qcow2 or other formats. Currently it would require a call to qemu-img which is not really a good idea for libvirt since it's hard to manage qemu-img or figure out whether it supports a given format (due to lacking introspection).

The formatting should be an asynchronous block job since it may take a long time if storage is blocked.

Comment 20 Miroslav Rezanina 2018-07-01 03:09:09 UTC
Fix included in qemu-kvm-rhev-2.12.0-6.el7

Comment 29 Qunfang Zhang 2018-07-11 07:50:12 UTC
Hello, Xianxian

Please help test this bug on Power.  Thanks!

Comment 30 xianwang 2018-07-13 04:37:23 UTC
(In reply to Qunfang Zhang from comment #29)
> Hello, Xianxian
> 
> Please help test this bug on Power.  Thanks!

I have test these two cases of comment28, they work well on powerpc
Host:
3.10.0-915.el7.ppc64le
qemu-kvm-rhev-2.12.0-7.el7.ppc64le
SLOF-20171214-2.gitfa98132.el7.noarch

Guest:
3.10.0-919.el7.ppc64

Comment 31 errata-xmlrpc 2018-11-01 11:01:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443