Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513292

Summary: rpm.org documentation does not cover conditional macro syntax
Product: [Fedora] Fedora Reporter: Evan Klitzke <evan>
Component: rpmAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ignatenko, mjw, packaging-team-maint, pmatilai, pmoravco, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-15 10:36:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Evan Klitzke 2017-11-15 05:57:53 UTC
I can maybe just send a GitHub pull request for this, although I would kind of prefer an RPM maintainer make the change since I don't know if there's other syntax that should be documented.

I recently came across a package that had a macro expansion of the form %{?foo:1}. I couldn't find this documented at http://rpm.org/user_doc/macros.html . Actually, even the form %{?foo} is not defined there. Eventually I found http://backreference.org/2011/09/17/some-tips-on-rpm-conditional-macros/ which explains the syntax, as well as another form %{!?foo:1}. These should both be documented.

Comment 1 Panu Matilainen 2017-11-15 10:36:21 UTC
Doh, can't disagree, that rather fundamental syntax is completely undocumented.

However this is not a Fedora issue but rpm.org upstream web-pages, so I took the liberty of moving this to the correct tracker:
https://github.com/rpm-software-management/rpm-web/issues/4

Anyway, thanks for pointing this out!