Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513098

Summary: RFE: man page for restorecon should document the -vv option availability and behavior
Product: Red Hat Enterprise Linux 7 Reporter: R P Herrold <herrold>
Component: policycoreutilsAssignee: Vit Mojzis <vmojzis>
Status: CLOSED CURRENTRELEASE QA Contact: Dalibor Pospíšil <dapospis>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: dwalsh, lvrabec, mgrepl, mmalik, plautrba, ssekidde
Target Milestone: rcKeywords: Documentation, EasyFix, FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: policycoreutils-2.5-21.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1260238 Environment:
Last Closed: 2018-04-04 11:53:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description R P Herrold 2017-11-14 18:22:40 UTC
+++ This bug was initially created as a clone of Bug #1260238 +++


--- Additional comment from Petr Lautrbach on 2016-07-19 15:20:07 EDT ---

You can use restorecon -vv if you need more verbose output:

# restorecon -vv /etc/machine-id
restorecon: /etc/machine-id not reset customized by admin to system_u:object_r:svirt_sandbox_file_t:s0

--- Additional comment from M. Scherer on 2016-07-19 15:39:35 EDT ---

I didn't knew there was 2 different level of verbosity, likely because that's neither in the man page, nor the --help output.

=============================

new matter:

the 'train track' summary at the top of the man page is:

SYNOPSIS
       restorecon [-R] [-n] [-p] [-v] [-e directory] pathname...

       restorecon -f infilename [-e directory] [-R] [-n] [-p] [-v] [-F]

as to the effect of the '-v' option, we see:

       -n     don't change any file labels (passive check).   To  display  the
              files whose labels would be changed, add -v.

       -v     show changes in file labels, if type or role  are  going  to  be
              changed.

---------------

the problem:

I had no idea until reading this bug that a behavior undocumented in the 'man' page existed 

The availability and the effect of multiple -v option repetition should be noted


As this is documentation,rather than function it is a low risk addition, and may well be an EASYFIX