Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1513006

Summary: Nothing on external monitor when resuming docked laptop
Product: [Fedora] Fedora Reporter: Jean-Pierre Rupp <xenog>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 27CC: airlied, ajax, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jeremy, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, russell.louks, steved, xenog
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-05 21:31:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jean-Pierre Rupp 2017-11-14 15:10:14 UTC
Description of problem:

When resuming a suspended laptop on the docking station, nothing is shown in external display, and laptop returns on its own to suspended state after awhile.

Version-Release number of selected component (if applicable):

4.13.12-300.fc27.x86_64

How reproducible:

Every time I dock my suspended Lenovo T450s on my Lenovo docking station, and then attempt to wake the computer up using the switch on the docking station, the external display is unresponsive and the laptop returns to suspended state on its own. 

Steps to Reproduce:
1. Suspend laptop.
2. Dock laptop with lid closed.
3. Press power button on docking station to wake laptop up.

Actual results:

Laptop wakes up briefly then returns to sleep. Nothing is displayed on the external screen.

Expected results:

Laptop wakes up and displays on external monitor. I can use laptop normally.

Additional info:

This is happening on a Lenovo ThinkPad T450s with a Lenovo docking station that has a DVI external display connected. I can use the external display if I boot the computer up while the computer is docked. I can also use the external display if I leave the laptop display open while the laptop is docked. As soon as I close the laptop lid, it goes to sleep. I did not mess with the options in `/etc/systemd/logind.conf`, leaving the defaults, which used to work well before with Kernel 4.13.9-300.fc27.

Comment 1 russell.louks 2017-11-22 00:24:36 UTC
Identical behaviour observed with Lenovo T460 in Lenovo ThinkPad Pro Docking Station.  

Additionally, If the lid of the 460 is opened while still in the docking station, resumption will proceed normally, and the lid can then be closed once resumption completes without resulting in suspension.

Comment 2 Laura Abbott 2018-02-20 19:50:58 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us. Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.15.3-300.f27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.

Comment 3 Jean-Pierre Rupp 2018-03-05 21:31:39 UTC
This problem is solved.